summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-17 23:47:29 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commitf82cef25cae00bda3e019a8e056b76f001f0f425 (patch)
treee97b56a643d3aa7c068f8c11c07e7a37b9bef857 /gnu/packages/perl.scm
parent67cc6d7380af0ea594710aeaa06f07272a8a50da (diff)
downloadguix-patches-f82cef25cae00bda3e019a8e056b76f001f0f425.tar
guix-patches-f82cef25cae00bda3e019a8e056b76f001f0f425.tar.gz
gnu: Add perl-test-files.
* gnu/packages/perl.scm (perl-test-files): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 47bb707444..edb0ba8198 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5562,6 +5562,31 @@ Test::Exception. It does much less, but should allow greater flexibility in
testing exception-throwing code with about the same amount of typing.")
(license (package-license perl))))
+(define-public perl-test-files
+ (package
+ (name "perl-test-files")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PH/PHILCROW/Test-Files-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1zn33yigznq7i1jr4yjr4lxvc6bn7znkbqdzj7slhc146pqapkln"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-algorithm-diff" ,perl-algorithm-diff)
+ ("perl-text-diff" ,perl-text-diff)))
+ (home-page "http://search.cpan.org/dist/Test-Files")
+ (synopsis "Ease software testing with files and directories")
+ (description "This library provides functions to enable testing of files
+and directories. For instance, the @code{file_ok} helper can test whether the
+contents of a file is equal to a particular string.")
+ (license (package-license perl))))
+
(define-public perl-test-harness
(package
(name "perl-test-harness")