summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-10 14:30:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-10 14:30:36 +0200
commit6985a1acb3e9cc4cad8b6f63d77154842d25c929 (patch)
tree4df49b9f438e0e466efb3d589027a62b39d49761 /gnu/packages/perl.scm
parent87eaa4207208e16e5e1b22b60ba4ff5c3d035023 (diff)
parentd0fff8f840afc17be40bdc49bff52ed08d5a1a7b (diff)
downloadguix-patches-6985a1acb3e9cc4cad8b6f63d77154842d25c929.tar
guix-patches-6985a1acb3e9cc4cad8b6f63d77154842d25c929.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 040206504d..896a474bba 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4056,6 +4057,41 @@ environment, other than a fixed list of specified variables. Compilation
errors are rethrown automatically.")
(license (package-license perl))))
+(define-public perl-eval-withlexicals
+ (package
+ (name "perl-eval-withlexicals")
+ (version "1.003006")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/H/HA/HAARG/Eval-WithLexicals-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0x09mq0q745cxkw3xgr0h7dil7p1pdq3l5299kj3mk2ijkk2gwb6"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-tinyrepl
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/tinyrepl")
+ `("PERL5LIB" ":" prefix
+ (,(getenv "PERL5LIB")
+ ,(string-append out "/lib/perl5/site_perl"))))
+ #t))))))
+ (propagated-inputs
+ `(("perl-moo" ,perl-moo)
+ ("perl-strictures" ,perl-strictures)))
+ (home-page "https://metacpan.org/release/Eval-WithLexicals")
+ (synopsis "Lexical scope evaluation library for Perl")
+ (description "The Eval::WithLexicals Perl library provides support for
+lexical scope evaluation. This package also includes the @command{tinyrepl}
+command, which can be used as a minimal Perl read-eval-print loop (REPL).")
+ (license (package-license perl))))
+
(define-public perl-exception-class
(package
(name "perl-exception-class")