summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-09 21:29:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-02 18:39:16 +0100
commit84e8b19fe150ae843d63ca7343aa7172f35153f3 (patch)
tree0184374186658c616ef52a2b41eb3ea44fdcc524 /gnu/packages/perl.scm
parent25c3cf3edb42eddc7fd8071fceba36cbf3656756 (diff)
downloadguix-patches-84e8b19fe150ae843d63ca7343aa7172f35153f3.tar
guix-patches-84e8b19fe150ae843d63ca7343aa7172f35153f3.tar.gz
gnu: Add perl-extutils-depends.
* gnu/packages/perl.scm (perl-extutils-depends): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 29c6b07b95..3470fc3cbe 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2699,6 +2699,29 @@ By itself it is not a particularly interesting module by any measure, however
it ties together a family of modern toolchain modules.")
(license (package-license perl))))
+(define-public perl-extutils-depends
+ (package
+ (name "perl-extutils-depends")
+ (version "0.405")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/"
+ "ExtUtils-Depends-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0b4ab9qmcihsfs2ajhn5qzg7nhazr68v3r0zvb7076smswd41mla"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-number-delta" ,perl-test-number-delta)))
+ (home-page "http://search.cpan.org/dist/ExtUtils-Depends")
+ (synopsis "Easily build XS extensions that depend on XS extensions")
+ (description
+ "This module tries to make it easy to build Perl extensions that use
+functions and typemaps provided by other perl extensions. This means that a
+perl extension is treated like a shared library that provides also a C and an
+XS interface besides the perl one.")
+ (license (package-license perl))))
+
(define-public perl-extutils-helpers
(package
(name "perl-extutils-helpers")