summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-09 21:47:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-02 18:39:16 +0100
commit6578c56728323a498c5c7cd85b5352a4b74dd4a5 (patch)
tree855e491128d11b5b79b3e838ce581a9430b87ceb /gnu/packages/perl.scm
parent38e29d03bfb89bba837799d182fbaeafb7bf095a (diff)
downloadguix-patches-6578c56728323a498c5c7cd85b5352a4b74dd4a5.tar
guix-patches-6578c56728323a498c5c7cd85b5352a4b74dd4a5.tar.gz
gnu: Add perl-xs-object-magic.
* gnu/packages/perl.scm (perl-xs-object-magic): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 38466b9953..cbd92a9701 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7732,6 +7732,30 @@ attribute names.")
;; modification, are permitted under any circumstances. No warranty.
(license public-domain)))
+(define-public perl-xs-object-magic
+ (package
+ (name "perl-xs-object-magic")
+ (version "0.04")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/F/FL/FLORA/"
+ "XS-Object-Magic-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03fghj7hq0fiicmfdxhmzfm4mzv7s097pgkd32ji7jnljvhm9six"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-extutils-depends" ,perl-extutils-depends)
+ ("perl-test-fatal" ,perl-test-fatal)))
+ (home-page "http://search.cpan.org/dist/XS-Object-Magic")
+ (synopsis "Opaque, extensible XS pointer backed objects using sv_magic")
+ (description
+ "This way of associating structs with Perl space objects is designed to
+supersede Perl's builtin @code{T_PTROBJ} with something that is extensible
+(structs can be associated with any data type) and opaque (the C pointer is
+neither visible nor modifiable from Perl space).")
+ (license (package-license perl))))
+
(define-public perl-yaml
(package
(name "perl-yaml")