summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:11:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:43 +0100
commit5d2ecbffb2fc191df39cc25ff73127bffa1d691b (patch)
tree8db67fd2fdebff8788882235512fb2f51e67b79b /gnu/packages/perl.scm
parent37e7a4929fcbbe677047b942d0f824738ccb0129 (diff)
downloadguix-patches-5d2ecbffb2fc191df39cc25ff73127bffa1d691b.tar
guix-patches-5d2ecbffb2fc191df39cc25ff73127bffa1d691b.tar.gz
gnu: Add perl-unicode-collate.
* gnu/packages/perl.scm (perl-unicode-collate): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 42601772a1..36db63d8be 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7270,6 +7270,29 @@ common serialisation formats such as JSON or CBOR.")
(description "This Perl module provides Unicode normalization forms.")
(license (package-license perl))))
+(define-public perl-unicode-collate
+ (package
+ (name "perl-unicode-collate")
+ (version "1.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SA/SADAHIRO/"
+ "Unicode-Collate-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lq4p3mqqljhhy8wyiyahris33j4m5qfzpi6iacmcqjzw5g4afbm"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-unicode-normalize" ,perl-unicode-normalize)))
+ (home-page "http://search.cpan.org/dist/Unicode-Collate")
+ (synopsis "Unicode collation algorithm")
+ (description "This package provides tools for sorting and comparing
+Unicode data.")
+ ;; The file Unicode/Collate/allkeys.txt is released under the Expat
+ ;; license.
+ (license (list (package-license perl) expat))))
+
(define-public perl-unicode-linebreak
(package
(name "perl-unicode-linebreak")