summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 16:01:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:39 +0100
commit3f1df54cc059abc326c6691ea305f6676bc89c8a (patch)
treeba3e41752d74c1bb23ddf7fe4f6041807c69bd1e /gnu/packages/perl.scm
parentd4ba9a5f210e62742fbd2e9a0cbcde3c1b504fd6 (diff)
downloadguix-patches-3f1df54cc059abc326c6691ea305f6676bc89c8a.tar
guix-patches-3f1df54cc059abc326c6691ea305f6676bc89c8a.tar.gz
gnu: Add perl-autovivification.
* gnu/packages/perl.scm (perl-autovivification): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e9f3dca15a..92d973b7b1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -266,6 +266,33 @@ manipulate, read, and write Zip archive files.")
list manipulation routines.")
(license (package-license perl))))
+(define-public perl-autovivification
+ (package
+ (name "perl-autovivification")
+ (version "0.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/V/VP/VPIT/"
+ "autovivification-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1422kw9fknv7rbjkgdfflg1q3mb69d3yryszp38dn0bgzkqhwkc1"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/autovivification")
+ (synopsis "Lexically disable autovivification")
+ (description "When an undefined variable is dereferenced, it gets silently
+upgraded to an array or hash reference (depending of the type of the
+dereferencing). This behaviour is called autovivification and usually does
+what you mean but it may be unnatural or surprising because your variables get
+populated behind your back. This is especially true when several levels of
+dereferencing are involved, in which case all levels are vivified up to the
+last, or when it happens in intuitively read-only constructs like
+@code{exists}. The pragma provided by this package lets you disable
+autovivification for some constructs and optionally throws a warning or an
+error when it would have happened.")
+ (license (package-license perl))))
+
(define-public perl-base
(package
(name "perl-base")