summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-09 21:40:31 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-02 18:39:16 +0100
commit38e29d03bfb89bba837799d182fbaeafb7bf095a (patch)
tree2b62bd64c74e8bb03128c36b832d4ce48e5b3bef /gnu/packages/perl.scm
parent84e8b19fe150ae843d63ca7343aa7172f35153f3 (diff)
downloadguix-patches-38e29d03bfb89bba837799d182fbaeafb7bf095a.tar
guix-patches-38e29d03bfb89bba837799d182fbaeafb7bf095a.tar.gz
gnu: Add perl-extutils-pkgconfig.
* gnu/packages/perl.scm (perl-extutils-pkgconfig): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3470fc3cbe..38466b9953 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -37,7 +37,8 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
- #:use-module (gnu packages perl-web))
+ #:use-module (gnu packages perl-web)
+ #:use-module (gnu packages pkg-config))
;;;
;;; Please: Try to add new module packages in alphabetic order.
@@ -2764,6 +2765,29 @@ C code in your Perl programs, there isn't a clear method to compile standard,
self-contained C libraries. This module main goal is to help in that task.")
(license (package-license perl))))
+(define-public perl-extutils-pkgconfig
+ (package
+ (name "perl-extutils-pkgconfig")
+ (version "1.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/"
+ "ExtUtils-PkgConfig-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cxh6w8vmyqmhl6afys2q6z6jkp1m6zvacpk70196zmk48p1kcv9"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://search.cpan.org/dist/ExtUtils-PkgConfig")
+ (synopsis "Simplistic interface to pkg-config")
+ (description
+ "@code{ExtUtils::PkgConfig} is a very simplistic interface to the
+@command{pkg-config} utility, intended for use in the @file{Makefile.PL}
+of perl extensions which bind libraries that @command{pkg-config} knows.
+It is really just boilerplate code that you would have written yourself.")
+ (license lgpl2.1+)))
+
(define-public perl-file-changenotify
(package
(name "perl-file-changenotify")