summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 21:59:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:39 +0100
commit296663839b35bbf6b69f3dd678ca9a463e3790ac (patch)
treedb26c2583aca0190301713f10ea37ae2dd46c949 /gnu/packages/perl.scm
parente0b6accf1902bf2cbcac6380d1d930c4c6a770b7 (diff)
downloadguix-patches-296663839b35bbf6b69f3dd678ca9a463e3790ac.tar
guix-patches-296663839b35bbf6b69f3dd678ca9a463e3790ac.tar.gz
gnu: Add perl-tie-cycle.
* gnu/packages/perl.scm (perl-tie-cycle): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8e4ec88cb8..aa275eaf8b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6656,6 +6656,25 @@ controlled with command line parameters. The default parameter settings
approximately follow the suggestions in the Perl Style Guide.")
(license gpl2+)))
+(define-public perl-tie-cycle
+ (package
+ (name "perl-tie-cycle")
+ (version "1.221")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/B/BD/BDFOY/Tie-Cycle-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "10g6kirf6jfaldckg98y4pl87vrm7grqlg6ymb7a9vhrznyn7qn6"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Tie-Cycle")
+ (synopsis "Cycle through a list of values")
+ (description "You use @code{Tie::Cycle} to go through a list over and over
+again. Once you get to the end of the list, you go back to the beginning.")
+ (license (package-license perl))))
+
(define-public perl-tie-ixhash
(package
(name "perl-tie-ixhash")