summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-22 12:57:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-22 12:57:37 +0200
commit378de69c59ee0700c67b10b38592c213821b41f2 (patch)
treeee9b6465430077a79cace3cb8fab1a85a8c1e4c5 /gnu/packages/perl.scm
parent049e02eaa258942515260a58c8d9ddfc4e7caffe (diff)
parentd8be338f16c7da4acfa55f29f58beaf908d3ad60 (diff)
downloadguix-patches-378de69c59ee0700c67b10b38592c213821b41f2.tar
guix-patches-378de69c59ee0700c67b10b38592c213821b41f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 840e0b763e..086e1fae03 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 humanitiesNerd <catonano@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1369,6 +1370,26 @@ contained in Appendix A of FIPS Publication 181, \"Standard for Automated
Password Generator\".")
(license (package-license perl))))
+(define-public perl-crypt-rc4
+ (package
+ (name "perl-crypt-rc4")
+ (version "2.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SI/SIFUKURT/Crypt-RC4-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1sp099cws0q225h6j4y68hmfd1lnv5877gihjs40f8n2ddf45i2y"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Crypt-RC4")
+ (synopsis "Perl implementation of the RC4 encryption algorithm")
+ (description "A pure Perl implementation of the RC4 algorithm.")
+ (license (package-license perl))))
+
(define-public perl-cwd-guard
(package
(name "perl-cwd-guard")
@@ -5157,6 +5178,29 @@ inherit from in order to allow your objects to generate unique cryptographic
signatures.")
(license (package-license perl))))
+(define-public perl-ole-storage-lite
+ (package
+ (name "perl-ole-storage-lite")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JM/JMCNAMARA/OLE-Storage_Lite-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "179cxwqxb0f9dpx8954nvwjmggxxi5ndnang41yav1dx6mf0abp7"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/OLE-Storage_Lite")
+ (synopsis "Read and write OLE storage files")
+ (description "This module allows you to read and write
+an OLE-Structured file. @dfn{OLE} (Object Linking and Embedding) is a
+technology to store hierarchical information such as links to other
+documents within a single file.")
+ (license (package-license perl))))
+
(define-public perl-package-anon
(package
(name "perl-package-anon")