summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarco Rimoldi <rimarko@libero.it>2024-02-21 20:30:32 +0100
committerChristopher Baines <mail@cbaines.net>2024-03-16 10:03:47 +0000
commitd99cec308c87c0bd8a5901d7a4a045bc54e902f7 (patch)
tree9f7780cd41038bd4d10df30d2347fc1b7cd14fa6 /gnu/packages/pdf.scm
parent9d8a52d3bd705b122558140a8bc00cbcf6756b72 (diff)
downloadguix-patches-d99cec308c87c0bd8a5901d7a4a045bc54e902f7.tar
guix-patches-d99cec308c87c0bd8a5901d7a4a045bc54e902f7.tar.gz
gnu: python-poppler-qt5: Update to 21.3.0.
* gnu/packages/pdf.scm (python-poppler-qt5): Update to 21.3.0. [build-system]: Change to pyproject. [inputs]: Change SIP to current version variant. * gnu/packages/patches/python-poppler-qt5-fix-build.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register said patch. Change-Id: I30d6e2a3180505091d8072ed452211b0bb3a0178 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm49
1 files changed, 17 insertions, 32 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 22f6c8651f..47518e73d1 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -434,40 +434,25 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(define-public python-poppler-qt5
(package
(name "python-poppler-qt5")
- (version "21.1.0")
+ (version "21.3.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-poppler-qt5" version))
- (sha256
- (base32
- "0b82gm4i75q5v19kfbq0h4y0b2vcwr2213zkhxh6l0h45kdndmxd"))
- (patches (search-patches "python-poppler-qt5-fix-build.patch"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-poppler-qt5" version))
+ (sha256
+ (base32 "1q3gvmsmsq3llf9mcbhlkryrgprqrw2z7wmnvagy180f3y2fhxxl"))))
+ (build-system pyproject-build-system)
(arguments
- `(;; There are no tests. The check phase just causes a rebuild.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "setup.py"
- ;; This check always fails, so disable it.
- (("if not check_qtxml\\(\\)")
- "if True"))
- ;; We need to pass an extra flag here. This cannot be in
- ;; configure-flags because it should not be passed for the
- ;; installation phase.
- ((@@ (guix build python-build-system) call-setuppy)
- "build_ext" (list (string-append "--pyqt-sip-dir="
- (assoc-ref inputs "python-pyqt")
- "/share/sip")) #t))))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list python-sip-4 python-pyqt poppler-qt5 qtbase-5))
- (home-page "https://pypi.org/project/python-poppler-qt5/")
- (synopsis "Python bindings for Poppler-Qt5")
+ `(;; The sipbuild.api backend builder expects a Python dictionary as per
+ ;; https://peps.python.org/pep-0517/#config-settings, but we
+ ;; give it lists and it fails. The next line is a workaround.
+ #:configure-flags '#nil
+ #:tests? #f))
+ (native-inputs (list pkg-config))
+ (inputs (list python-sip python-pyqt-builder python-pyqt poppler-qt5
+ qtbase-5))
+ (home-page "https://github.com/frescobaldi/python-poppler-qt5")
+ (synopsis "Python binding to Poppler-Qt5")
(description
"This package provides Python bindings for the Qt5 interface of the
Poppler PDF rendering library.")