summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-07-09 18:01:02 -0400
committerMark H Weaver <mhw@netris.org>2017-07-10 12:59:07 -0400
commitef019092b98e1337acac51525e8e4e092267f69c (patch)
tree2abf43d5eac908af3d9ebdda8711eb0fb110aa8b /gnu/packages/pdf.scm
parent2a9a2207637a1e954c2f4677290ce6a39558ac88 (diff)
downloadguix-patches-ef019092b98e1337acac51525e8e4e092267f69c.tar
guix-patches-ef019092b98e1337acac51525e8e4e092267f69c.tar.gz
gnu: poppler: Fix null pointer dereferences.
* gnu/packages/patches/poppler-fix-crash-with-broken-documents.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/pdf.scm (poppler/fixed)[source]: Add the patch.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ffd7634eab..7b76955e23 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -135,7 +135,8 @@
(source
(origin
(inherit (package-source poppler))
- (patches (search-patches "poppler-CVE-2017-9776.patch"))))))
+ (patches (search-patches "poppler-fix-crash-with-broken-documents.patch"
+ "poppler-CVE-2017-9776.patch"))))))
(define-public poppler-qt4
(package/inherit poppler