summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-02 18:47:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-06 23:16:46 +0300
commitd5d296382611d9de900d160968bf82c006caaaa7 (patch)
treeeba6ea1c9e93d80f2216c186eee02c9f79a0dc52 /gnu/packages/patches
parentae1873558ca0d19383bce07a2c8867e1a5cf45cc (diff)
downloadguix-patches-d5d296382611d9de900d160968bf82c006caaaa7.tar
guix-patches-d5d296382611d9de900d160968bf82c006caaaa7.tar.gz
gnu: wmfire: Fix build.
* gnu/packages/gnustep.scm (wmfire)[source]: Add patch. * gnu/packages/patches/wmfire-dont-inline-draw-fire.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I3e937c5e9dbd8a5e2eebfd92213407d9477a47ab
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/wmfire-dont-inline-draw-fire.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/wmfire-dont-inline-draw-fire.patch b/gnu/packages/patches/wmfire-dont-inline-draw-fire.patch
new file mode 100644
index 0000000000..b36124b268
--- /dev/null
+++ b/gnu/packages/patches/wmfire-dont-inline-draw-fire.patch
@@ -0,0 +1,33 @@
+https://sources.debian.org/data/main/w/wmfire/1.2.4-7/debian/patches/08_removed-inline-from-function-with-extern-linkage.patch
+
+Description: remove inline from function with extern linkage
+ Fixes FTBFS with gcc 9.
+Author: Jeremy Sowden <jeremy@azazel.net>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925858
+Last-Update: 2019-06-22
+Forwarded: not-needed
+
+---
+ src/wmfire.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/src/wmfire.c
++++ b/src/wmfire.c
+@@ -111,7 +111,7 @@
+ void change_flame(int);
+ GdkCursor *setup_cursor();
+ void burn_spot(int, int, int);
+-inline void draw_fire(unsigned int);
++void draw_fire(unsigned int);
+ static void make_wmfire_dockapp();
+ void read_config(int, char **);
+ void do_help(void);
+@@ -504,7 +504,7 @@
+ /* Draw fire */
+ /******************************************/
+
+-inline void
++void
+ draw_fire(unsigned int load)
+ {
+ int x, y, i, j;