summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-03-29 21:16:07 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-06-07 09:35:40 +0200
commitd03fcff19d02f7a1df49b3b675297b3bc97375dd (patch)
treeb9b53c732138a1b1ea566bc91fe502f0f5f5ca1d /gnu/packages/patches
parent1718d2ebd2352fd15ec9446f81fb01d41f3e705a (diff)
downloadguix-patches-d03fcff19d02f7a1df49b3b675297b3bc97375dd.tar
guix-patches-d03fcff19d02f7a1df49b3b675297b3bc97375dd.tar.gz
gnu: sbcl: Update to 2.4.5.
* gnu/packages/lisp.scm (sbcl): Update to 2.4.5. [source]: Remove obsolete patches. [inputs]: Add bash-minimal. [arguments]: Remove trailing booleans. * gnu/local.mk (dist_patch_DATA): Remove obsolete patches. * gnu/packages/patches/sbcl-fix-ppc64-build.patch: Remove file. * gnu/packages/patches/sbcl-fix-riscv-build.patch: Remove file. Change-Id: Id918ee31aec016b987b0831680847b502c88fb5c
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/sbcl-fix-ppc64-build.patch27
-rw-r--r--gnu/packages/patches/sbcl-fix-riscv-build.patch19
2 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/patches/sbcl-fix-ppc64-build.patch b/gnu/packages/patches/sbcl-fix-ppc64-build.patch
deleted file mode 100644
index a7d4d9a21e..0000000000
--- a/gnu/packages/patches/sbcl-fix-ppc64-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-commit 255f3ead060129aa097b62f10d054cdc4997a431
-Author: Douglas Katzman <dougk@google.com>
-Date: Mon Jan 1 23:59:50 2024 -0500
-
- Fix ppc64 failure-to-build (from a few weeks ago)
-
- Git rev 7354472bb5 caused NIL to get a bogus widetag.
-
-diff --git a/make-target-2-load.lisp b/make-target-2-load.lisp
-index 6571ec27d..daef942ea 100644
---- a/make-target-2-load.lisp
-+++ b/make-target-2-load.lisp
-@@ -339,7 +339,13 @@ Please check that all strings which were not recognizable to the compiler
-
-
- (do-all-symbols (symbol)
-- (sb-kernel:logior-header-bits symbol sb-vm::+symbol-initial-core+)
-+ ;; Don't futz with the header of static symbols.
-+ ;; Technically LOGIOR-HEADER-BITS can only be used on an OTHER-POINTER-LOWTAG
-+ ;; objects, so modifying NIL should not ever work, but it's especially wrong
-+ ;; on ppc64 where OTHER- and LIST- pointer lowtags are 10 bytes apart instead
-+ ;; of 8, so this was making a random alteration to the header.
-+ (unless (eq (heap-allocated-p symbol) :static)
-+ (sb-kernel:logior-header-bits symbol sb-vm::+symbol-initial-core+))
-
- ;; A symbol whose INFO slot underwent any kind of manipulation
- ;; such that it now has neither properties nor globaldb info,
diff --git a/gnu/packages/patches/sbcl-fix-riscv-build.patch b/gnu/packages/patches/sbcl-fix-riscv-build.patch
deleted file mode 100644
index 3e01ee6579..0000000000
--- a/gnu/packages/patches/sbcl-fix-riscv-build.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit b286d92af7468164c155c70d38213211b296fdfe
-Author: Douglas Katzman <dougk@google.com>
-Date: Wed Jan 10 11:46:55 2024 -0500
-
- Fix riscv build
-
-diff --git a/src/compiler/riscv/float.lisp b/src/compiler/riscv/float.lisp
-index ce46d24ac..a16380293 100644
---- a/src/compiler/riscv/float.lisp
-+++ b/src/compiler/riscv/float.lisp
-@@ -578,7 +578,7 @@
- (:results (res :scs (double-reg)))
- (:arg-types signed-num)
- (:result-types double-float)
-- (:translate make-double-float)
-+ (:translate %make-double-float)
- (:policy :fast-safe)
- (:generator 2
- (inst fmvx-> :double res bits)))