summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-29 00:44:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-29 21:15:39 -0400
commita05c130435d559bcea8dd213294ae7e8159b1d51 (patch)
tree9b78d7f6641915fe1772af0653931a86dc322949 /gnu/packages/patches
parent9ed847f8289b4a6f1855c0aa0cba9c94e09a9dc8 (diff)
downloadguix-patches-a05c130435d559bcea8dd213294ae7e8159b1d51.tar
guix-patches-a05c130435d559bcea8dd213294ae7e8159b1d51.tar.gz
gnu: jami: Work toward reinstating functional tests.
* gnu/packages/patches/jami-enable-testing.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/jami.scm (jami) [source]: Apply it. [phases] <check>: Use 'ctest' to run tests. Update comment explaining why the QML test suite is disabled. Change-Id: I5c9333a3b5064ecec9a2dd4fe13ae597d5354b7c
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/jami-enable-testing.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/jami-enable-testing.patch b/gnu/packages/patches/jami-enable-testing.patch
new file mode 100644
index 0000000000..3e27a8def9
--- /dev/null
+++ b/gnu/packages/patches/jami-enable-testing.patch
@@ -0,0 +1,26 @@
+Fix an issue where ctest wouldn't find the qml test files.
+Upstream status: forwarded to jami@gnu.org
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e802357f..75cffda2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -884,5 +884,6 @@ qt_finalize_executable(${PROJECT_NAME})
+ # tests
+ if(BUILD_TESTING)
+ message("Add Jami tests")
++ enable_testing()
+ add_subdirectory(${TESTS_DIR})
+ endif()
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 37796e52..06008ccf 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 3.16)
+
+-enable_testing(true)
++enable_testing()
+
+ set(QT_TESTING_MODULES
+ ${QT_MODULES}