summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:49:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:39 -0400
commit64c86457db9dceafc3453967e9f6c6fec776ab13 (patch)
treec16ceb2913cd0125d5de458bece086da3e34243a /gnu/packages/patches
parent787e582c47f4de3bb8dea14a2041c272d8240d0f (diff)
downloadguix-patches-64c86457db9dceafc3453967e9f6c6fec776ab13.tar
guix-patches-64c86457db9dceafc3453967e9f6c6fec776ab13.tar.gz
gnu: Remove python2-subprocess32.
* gnu/packages/python-xyz.scm (python2-subprocess32): Delete variable. * gnu/packages/patches/python2-subprocess32-disable-input-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python2-subprocess32-disable-input-test.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch b/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
deleted file mode 100644
index 05b4eef1ba..0000000000
--- a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-This test tries to send a KeyboardInterrupt, which does
-not work in the build environment.
-
---- a/test_subprocess32.py 2017-03-06 22:21:49.334045485 +0100
-+++ b/test_subprocess32.py 2017-03-06 22:22:02.490439949 +0100
-@@ -1299,12 +1299,6 @@
- getattr(p, method)(*args)
- return p
-
-- def test_send_signal(self):
-- p = self._kill_process('send_signal', signal.SIGINT)
-- _, stderr = p.communicate()
-- self.assertIn('KeyboardInterrupt', stderr)
-- self.assertNotEqual(p.wait(), 0)
--
- def test_kill(self):
- p = self._kill_process('kill')
- _, stderr = p.communicate()