summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-02-11 19:12:36 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2021-02-11 19:12:36 +0100
commitabd318ff4b741eac11227778bf2e569ee7b186ff (patch)
tree6abc09a3e01914d891124e9d0dda0f4e0979c485 /gnu/packages/patches
parent71cb6dfe10540718eb337e7e2248fc809394894b (diff)
parentc5dc87fee840ad620b01637dc4f9ffa5efc9270c (diff)
downloadguix-patches-abd318ff4b741eac11227778bf2e569ee7b186ff.tar
guix-patches-abd318ff4b741eac11227778bf2e569ee7b186ff.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/clementine-fix-sqlite.patch23
-rw-r--r--gnu/packages/patches/clementine-remove-crypto++-dependency.patch19
-rw-r--r--gnu/packages/patches/clementine-use-openssl.patch67
-rw-r--r--gnu/packages/patches/emacs-undohist-ignored.patch27
-rw-r--r--gnu/packages/patches/hdf5-1.8-mpi-deprecations.patch169
-rw-r--r--gnu/packages/patches/owncloud-disable-updatecheck.patch8
-rw-r--r--gnu/packages/patches/qpdfview-qt515-compat.patch17
-rw-r--r--gnu/packages/patches/renpy-use-system-fribidi.patch23
-rw-r--r--gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch83
-rw-r--r--gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch29
-rw-r--r--gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch44
11 files changed, 35 insertions, 474 deletions
diff --git a/gnu/packages/patches/clementine-fix-sqlite.patch b/gnu/packages/patches/clementine-fix-sqlite.patch
deleted file mode 100644
index f9d44f9074..0000000000
--- a/gnu/packages/patches/clementine-fix-sqlite.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Patch downloaded from https://github.com/clementine-player/Clementine/pull/5669 .
-
-diff -ruN clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp clementine-1.3.1.565.gd20c2244a/src/core/database.cpp
---- clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp 2018-07-07 23:59:24.018540126 +0200
-+++ clementine-1.3.1.565.gd20c2244a/src/core/database.cpp 2018-07-08 00:04:47.991551728 +0200
-@@ -265,6 +265,17 @@
- StaticInit();
-
- {
-+
-+#ifdef SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER
-+ // In case sqlite>=3.12 is compiled without -DSQLITE_ENABLE_FTS3_TOKENIZER
-+ // (generally a good idea due to security reasons) the fts3 support should be enabled explicitly.
-+ QVariant v = db.driver()->handle();
-+ if (v.isValid() && qstrcmp(v.typeName(), "sqlite3*") == 0) {
-+ sqlite3 *handle = *static_cast<sqlite3**>(v.data());
-+ if (handle) sqlite3_db_config(handle, SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER, 1, NULL);
-+ }
-+#endif
-+
- QSqlQuery set_fts_tokenizer(db);
- set_fts_tokenizer.prepare("SELECT fts3_tokenizer(:name, :pointer)");
- set_fts_tokenizer.bindValue(":name", "unicode");
diff --git a/gnu/packages/patches/clementine-remove-crypto++-dependency.patch b/gnu/packages/patches/clementine-remove-crypto++-dependency.patch
deleted file mode 100644
index e7cf80ddee..0000000000
--- a/gnu/packages/patches/clementine-remove-crypto++-dependency.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3202b8b..473ecb9 100755
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -279,14 +279,6 @@ optional_component(LIBPULSE ON "Pulse audio integration"
-
- optional_component(VISUALISATIONS ON "Visualisations")
-
--if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
-- message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
-- "code must be compiled in")
--elseif(CRYPTOPP_FOUND)
-- set(HAVE_CRYPTOPP ON)
-- set(HAVE_SPOTIFY_DOWNLOADER ON)
--endif()
--
- # Find DBus if it's enabled
- if (HAVE_DBUS)
- find_package(Qt5 COMPONENTS DBus)
diff --git a/gnu/packages/patches/clementine-use-openssl.patch b/gnu/packages/patches/clementine-use-openssl.patch
deleted file mode 100644
index 1fbf3d2b8a..0000000000
--- a/gnu/packages/patches/clementine-use-openssl.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4022c383b..3202b8b69 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -83,6 +83,7 @@ pkg_check_modules(LIBPULSE libpulse)
- pkg_check_modules(LIBXML libxml-2.0)
- pkg_check_modules(SPOTIFY libspotify>=12.1.45)
- pkg_check_modules(TAGLIB REQUIRED taglib>=1.6)
-+pkg_check_modules(OPENSSL REQUIRED openssl)
-
- if (WIN32)
- find_package(ZLIB REQUIRED)
-@@ -381,20 +382,6 @@ if(GMOCK_INCLUDE_DIRS)
- endif(GTEST_INCLUDE_DIRS)
- endif(GMOCK_INCLUDE_DIRS)
-
--# Use the system's sha2 if it's available.
--find_path(SHA2_INCLUDE_DIRS sha2.h)
--find_library(SHA2_LIBRARIES sha2)
--if(SHA2_LIBRARIES AND SHA2_INCLUDE_DIRS)
-- message(STATUS "Using system sha2 library")
-- set(USE_SYSTEM_SHA2 ON)
--else()
-- message(STATUS "Using builtin sha2 library")
-- set(USE_SYSTEM_SHA2 OFF)
-- add_subdirectory(3rdparty/sha2)
-- set(SHA2_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/sha2)
-- set(SHA2_LIBRARIES sha2)
--endif()
--
- # Use the system libmygpo-qt5 if a recent enough version was found
- if(LIBMYGPO_QT5_FOUND)
- set(MYGPOQT5_LIBRARIES ${LIBMYGPO_QT5_LIBRARIES})
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 6e24c9726..104d044d9 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -29,7 +29,6 @@ include_directories(${LIBPROJECTM_INCLUDE_DIRS})
- include_directories(${QTSINGLEAPPLICATION_INCLUDE_DIRS})
- include_directories(${QTIOCOMPRESSOR_INCLUDE_DIRS})
- include_directories(${QXT_INCLUDE_DIRS})
--include_directories(${SHA2_INCLUDE_DIRS})
- include_directories(${CHROMAPRINT_INCLUDE_DIRS})
- include_directories(${MYGPOQT5_INCLUDE_DIRS})
-
-@@ -1223,7 +1222,7 @@ target_link_libraries(clementine_lib
- libclementine-common
- libclementine-tagreader
- libclementine-remote
-- ${SHA2_LIBRARIES}
-+ ${OPENSSL_LIBRARIES}
- ${TAGLIB_LIBRARIES}
- ${MYGPOQT5_LIBRARIES}
- ${CHROMAPRINT_LIBRARIES}
-diff --git a/src/core/utilities.cpp b/src/core/utilities.cpp
-index ce76f22da..80bf623fb 100644
---- a/src/core/utilities.cpp
-+++ b/src/core/utilities.cpp
-@@ -52,7 +52,7 @@
- #include "config.h"
- #include "timeconstants.h"
-
--#include "sha2.h"
-+#include <openssl/sha.h>
-
- #if defined(Q_OS_UNIX)
- #include <sys/statvfs.h>
diff --git a/gnu/packages/patches/emacs-undohist-ignored.patch b/gnu/packages/patches/emacs-undohist-ignored.patch
deleted file mode 100644
index c1ad827a26..0000000000
--- a/gnu/packages/patches/emacs-undohist-ignored.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 52bfd419bf9022726048f818d955b8ea10a16d5c Mon Sep 17 00:00:00 2001
-From: Patrick Mosby <info@schreiblogade.de>
-Date: Mon, 7 Sep 2015 09:05:56 +0200
-Subject: [PATCH] Don't save undo file for ignored files.
-
-This fixes #4.
----
- undohist.el | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/undohist.el b/undohist.el
-index b184a26..de60356 100644
---- a/undohist.el
-+++ b/undohist.el
-@@ -164,7 +164,8 @@ To use undohist, you just call this function."
- undohist-ignored-files)))
-
- (defun undohist-save-1 ()
-- (when (consp buffer-undo-list)
-+ (when (and (consp buffer-undo-list)
-+ (undohist-recover-file-p (buffer-file-name (current-buffer))))
- (let ((file (make-undohist-file-name (buffer-file-name)))
- (contents `((digest . ,(md5 (current-buffer)))
- (undo-list . ,(undohist-encode buffer-undo-list)))))
---
-2.21.0
-
diff --git a/gnu/packages/patches/hdf5-1.8-mpi-deprecations.patch b/gnu/packages/patches/hdf5-1.8-mpi-deprecations.patch
deleted file mode 100644
index 29242dc4e8..0000000000
--- a/gnu/packages/patches/hdf5-1.8-mpi-deprecations.patch
+++ /dev/null
@@ -1,169 +0,0 @@
---- a/src/H5.c
-+++ b/src/H5.c
-@@ -138,7 +138,7 @@
- if (mpi_initialized && !mpi_finalized) {
- int key_val;
-
-- if(MPI_SUCCESS != (mpi_code = MPI_Comm_create_keyval(MPI_NULL_COPY_FN,
-+ if(MPI_SUCCESS != (mpi_code = MPI_Comm_create_keyval(MPI_COMM_NULL_COPY_FN,
- (MPI_Comm_delete_attr_function *)H5_mpi_delete_cb,
- &key_val, NULL)))
- HMPI_GOTO_ERROR(FAIL, "MPI_Comm_create_keyval failed", mpi_code)
---- hdf5-1.8.19/testpar/t_cache.c
-+++ hdf5-1.8.19/testpar/t_cache.c
-@@ -1187,20 +1187,20 @@
- struct mssg_t sample; /* used to compute displacements */
-
- /* setup the displacements array */
-- if ( ( MPI_SUCCESS != MPI_Address(&sample.req, &displs[0]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.src, &displs[1]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.dest, &displs[2]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.mssg_num, &displs[3]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.base_addr, &displs[4]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.len, &displs[5]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.ver, &displs[6]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.count, &displs[7]) ) ||
-- ( MPI_SUCCESS != MPI_Address(&sample.magic, &displs[8]) ) ) {
-+ if ( ( MPI_SUCCESS != MPI_Get_address(&sample.req, &displs[0]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.src, &displs[1]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.dest, &displs[2]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.mssg_num, &displs[3]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.base_addr, &displs[4]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.len, &displs[5]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.ver, &displs[6]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.count, &displs[7]) ) ||
-+ ( MPI_SUCCESS != MPI_Get_address(&sample.magic, &displs[8]) ) ) {
-
- nerrors++;
- success = FALSE;
- if ( verbose ) {
-- HDfprintf(stdout, "%d:%s: MPI_Address() call failed.\n",
-+ HDfprintf(stdout, "%d:%s: MPI_Get_address() call failed.\n",
- world_mpi_rank, fcn_name);
- }
-
-@@ -1215,14 +1215,14 @@
-
- if ( success ) {
-
-- result = MPI_Type_struct(9, block_len, displs, mpi_types, &mpi_mssg_t);
-+ result = MPI_Type_create_struct(9, block_len, displs, mpi_types, &mpi_mssg_t);
-
- if ( result != MPI_SUCCESS ) {
-
- nerrors++;
- success = FALSE;
- if ( verbose ) {
-- HDfprintf(stdout, "%d:%s: MPI_Type_struct() call failed.\n",
-+ HDfprintf(stdout, "%d:%s: MPI_Type_create_struct() call failed.\n",
- world_mpi_rank, fcn_name);
- }
- }
---- hdf5-1.8.19/testpar/t_mpi.c
-+++ hdf5-1.8.19/testpar/t_mpi.c
-@@ -279,7 +279,7 @@
- printf("Skipped GB file range test "
- "because MPI_Offset cannot support it\n");
- }else{
-- buf = HDmalloc(MB);
-+ buf = (char *)HDmalloc(MB);
- VRFY((buf!=NULL), "malloc succeed");
-
- /* open a new file. Remove it first in case it exists. */
-@@ -624,7 +624,7 @@
- and this platform.
-
- 1. Details for the test:
--1) Create two derived datatypes with MPI_Type_hindexed:
-+1) Create two derived datatypes with MPI_Type_create_hindexed:
- datatype1:
- count = 1, blocklens = 1, offsets = 0,
- base type = MPI_BYTE(essentially a char)
-@@ -633,7 +633,7 @@
- base type = MPI_BYTE
-
- 2) Using these two derived datatypes,
-- Build another derived datatype with MPI_Type_struct:
-+ Build another derived datatype with MPI_Type_create_struct:
- advtype: derived from datatype1 and datatype2
- advtype:
- count = 2, blocklens[0] = 1, blocklens[1]=1,
-@@ -676,10 +676,9 @@
- int mpi_err_strlen;
- int mpi_err;
- int i;
-- int nerrors = 0; /* number of errors */
- MPI_Datatype etype,filetype;
- MPI_Datatype adv_filetype,bas_filetype[2];
-- MPI_Datatype etypenew, filetypenew;
-+ MPI_Datatype filetypenew;
- MPI_Offset disp;
- MPI_Status Status;
- MPI_Aint adv_disp[2];
-@@ -715,7 +714,7 @@
- blocklens[0] = 1;
- offsets[0] = 0;
-
-- if((mpi_err= MPI_Type_hindexed(count,blocklens,offsets,MPI_BYTE,&filetype))
-+ if((mpi_err= MPI_Type_create_hindexed(count,blocklens,offsets,MPI_BYTE,&filetype))
- != MPI_SUCCESS){
- MPI_Error_string(mpi_err, mpi_err_str, &mpi_err_strlen);
- printf("MPI_Type_contiguous failed (%s)\n", mpi_err_str);
-@@ -731,7 +730,7 @@
- count = 1;
- blocklens[0]=1;
- offsets[0] = 1;
-- if((mpi_err= MPI_Type_hindexed(count,blocklens,offsets,MPI_BYTE,&filetypenew))
-+ if((mpi_err= MPI_Type_create_hindexed(count,blocklens,offsets,MPI_BYTE,&filetypenew))
- != MPI_SUCCESS){
- MPI_Error_string(mpi_err, mpi_err_str, &mpi_err_strlen);
- printf("MPI_Type_contiguous failed (%s)\n", mpi_err_str);
-@@ -752,10 +751,10 @@
- bas_filetype[0] = filetype;
- bas_filetype[1] = filetypenew;
-
-- if((mpi_err= MPI_Type_struct(outcount,adv_blocklens,adv_disp,bas_filetype,&adv_filetype))
-+ if((mpi_err= MPI_Type_create_struct(outcount,adv_blocklens,adv_disp,bas_filetype,&adv_filetype))
- != MPI_SUCCESS){
- MPI_Error_string(mpi_err, mpi_err_str, &mpi_err_strlen);
-- printf("MPI_Type_struct failed (%s)\n", mpi_err_str);
-+ printf("MPI_Type_create_struct failed (%s)\n", mpi_err_str);
- return 1;
- }
- if((mpi_err=MPI_Type_commit(&adv_filetype))!=MPI_SUCCESS){
-@@ -842,7 +841,7 @@
- processes are needed.
-
- 1. Details for the test:
--1) Create one derived datatype with MPI_Type_hindexed:
-+1) Create one derived datatype with MPI_Type_create_hindexed:
-
- 2) Choosing at least two processes to contribute none for IO with
- the buf size inside MPI_Write_at_all to 0.
-@@ -898,7 +897,7 @@
- offsets[1] = (mpi_size+mpi_rank)*count;
-
- if(count !=0) {
-- if((mpi_err = MPI_Type_hindexed(2,
-+ if((mpi_err = MPI_Type_create_hindexed(2,
- blocklens,
- offsets,
- etype,
-@@ -914,7 +913,7 @@
- return 1;
- } /* end if */
-
-- if((mpi_err = MPI_Type_hindexed(2,
-+ if((mpi_err = MPI_Type_create_hindexed(2,
- blocklens,
- offsets,
- etype,
-@@ -1098,7 +1097,7 @@
- * calls. By then, MPI calls may not work.
- */
- if (H5dont_atexit() < 0){
-- printf("Failed to turn off atexit processing. Continue.\n", mpi_rank);
-+ printf("Failed to turn off atexit processing. Continue.\n");
- };
- H5open();
- if (parse_options(argc, argv) != 0){
diff --git a/gnu/packages/patches/owncloud-disable-updatecheck.patch b/gnu/packages/patches/owncloud-disable-updatecheck.patch
index 3469398eb4..d495a9dec2 100644
--- a/gnu/packages/patches/owncloud-disable-updatecheck.patch
+++ b/gnu/packages/patches/owncloud-disable-updatecheck.patch
@@ -14,11 +14,11 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
if (connection.isEmpty())
con = defaultConnection();
-- QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
-+ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
- fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
+- QVariant fallback = getValue(skipUpdateCheckC(), con, false);
++ QVariant fallback = getValue(skipUpdateCheckC(), con, true);
+ fallback = getValue(skipUpdateCheckC(), QString(), fallback);
- QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
+ QVariant value = getPolicySetting(skipUpdateCheckC(), fallback);
- return value.toBool();
+ if ( !value.toBool() )
+ qDebug() << "Guix has disabled the UpdateCheck mechanism.";
diff --git a/gnu/packages/patches/qpdfview-qt515-compat.patch b/gnu/packages/patches/qpdfview-qt515-compat.patch
new file mode 100644
index 0000000000..1fbf5ec3f1
--- /dev/null
+++ b/gnu/packages/patches/qpdfview-qt515-compat.patch
@@ -0,0 +1,17 @@
+Fix compatibility with Qt 5.15.
+
+Patch copied from upstream source repository:
+
+https://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/revision/2104
+
+--- a/sources/model.h 2017-04-19 21:01:25 +0000
++++ b/sources/model.h 2020-06-09 06:24:11 +0000
+@@ -24,6 +24,7 @@
+ #define DOCUMENTMODEL_H
+
+ #include <QList>
++#include <QPainterPath>
+ #include <QtPlugin>
+ #include <QWidget>
+ #include <QVector>
+
diff --git a/gnu/packages/patches/renpy-use-system-fribidi.patch b/gnu/packages/patches/renpy-use-system-fribidi.patch
index 1437274bcc..913415e317 100644
--- a/gnu/packages/patches/renpy-use-system-fribidi.patch
+++ b/gnu/packages/patches/renpy-use-system-fribidi.patch
@@ -2,22 +2,27 @@ See also [Arch] and [Gentoo] for similar patches in other distros.
[Arch] https://github.com/archlinux/svntogit-community/blob/packages/renpy/trunk/renpy-system-fribidi.patch
[Gentoo] https://gitweb.gentoo.org/repo/gentoo.git/tree/games-engines/renpy/files/renpy-7.3.5-use-system-fribidi.patch
-Index: renpy-7.3.5-source/module/renpybidicore.c
+Index: renpy-7.4.0-source/module/renpybidicore.c
===================================================================
---- renpy-7.3.5-source.orig/module/renpybidicore.c
-+++ renpy-7.3.5-source/module/renpybidicore.c
-@@ -1,5 +1,5 @@
+--- renpy-7.4.0-source.orig/module/renpybidicore.c
++++ renpy-7.4.0-source/module/renpybidicore.c
+@@ -1,9 +1,3 @@
#include <Python.h>
+-
+-#ifdef RENPY_BUILD
+ #include <fribidi.h>
+-#else
-#include <fribidi-src/lib/fribidi.h>
-+#include <fribidi.h>
+-#endif
+-
#include <stdlib.h>
#ifndef alloca
-Index: renpy-7.3.5-source/module/setup.py
+Index: renpy-7.4.0-source/module/setup.py
===================================================================
---- renpy-7.3.5-source.orig/module/setup.py
-+++ renpy-7.3.5-source/module/setup.py
-@@ -119,30 +119,13 @@ cython(
+--- renpy-7.4.0-source.orig/module/setup.py
++++ renpy-7.4.0-source/module/setup.py
+@@ -125,30 +125,13 @@ cython(
sdl + [ png, 'z', 'm' ])
FRIBIDI_SOURCES = """
diff --git a/gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch b/gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch
deleted file mode 100644
index 6e389dd59e..0000000000
--- a/gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From: Petter Reinholdtsen <pere@debian.org>
-Date: Tue, 22 Sep 2015 15:14:06 +0200
-Subject: oggenc: validate count of channels in the header (CVE-2014-9638 &
- CVE-2014-9639)
-
-Author: Kamil Dudka <kdudka@redhat.com>
-Origin: http://lists.xiph.org/pipermail/vorbis-dev/2015-February/020423.html
-Bug: https://trac.xiph.org/ticket/2136
-Bug: https://trac.xiph.org/ticket/2137
-Bug-Debian: https://bugs.debian.org/776086
-Forwarded: not-needed
-Reviewed-By: Petter Reinholdtsen <pere@hungry.com>
-Last-Update: 2015-09-22
----
- oggenc/audio.c | 18 ++++++++++++++++--
- 1 file changed, 16 insertions(+), 2 deletions(-)
-
-diff --git a/oggenc/audio.c b/oggenc/audio.c
-index 05e42b3..1b3f179 100644
---- a/oggenc/audio.c
-+++ b/oggenc/audio.c
-@@ -13,6 +13,7 @@
- #include <config.h>
- #endif
-
-+#include <limits.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -251,6 +252,7 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
- aiff_fmt format;
- aifffile *aiff = malloc(sizeof(aifffile));
- int i;
-+ long channels;
-
- if(buf[11]=='C')
- aifc=1;
-@@ -277,11 +279,16 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
- return 0;
- }
-
-- format.channels = READ_U16_BE(buffer);
-+ format.channels = channels = READ_U16_BE(buffer);
- format.totalframes = READ_U32_BE(buffer+2);
- format.samplesize = READ_U16_BE(buffer+6);
- format.rate = (int)read_IEEE80(buffer+8);
-
-+ if(channels <= 0L || SHRT_MAX < channels)
-+ {
-+ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
-+ return 0;
-+ }
- aiff->bigendian = 1;
-
- if(aifc)
-@@ -412,6 +419,7 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
- wav_fmt format;
- wavfile *wav = malloc(sizeof(wavfile));
- int i;
-+ long channels;
-
- /* Ok. At this point, we know we have a WAV file. Now we have to detect
- * whether we support the subtype, and we have to find the actual data
-@@ -449,12 +457,18 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
- }
-
- format.format = READ_U16_LE(buf);
-- format.channels = READ_U16_LE(buf+2);
-+ format.channels = channels = READ_U16_LE(buf+2);
- format.samplerate = READ_U32_LE(buf+4);
- format.bytespersec = READ_U32_LE(buf+8);
- format.align = READ_U16_LE(buf+12);
- format.samplesize = READ_U16_LE(buf+14);
-
-+ if(channels <= 0L || SHRT_MAX < channels)
-+ {
-+ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
-+ return 0;
-+ }
-+
- if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
- {
- if(len<40)
diff --git a/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch b/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch
deleted file mode 100644
index 97d18e0db7..0000000000
--- a/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: vorbis-tools/oggenc/oggenc.c
-===================================================================
---- vorbis-tools/oggenc/oggenc.c (revision 19116)
-+++ vorbis-tools/oggenc/oggenc.c (revision 19117)
-@@ -98,4 +98,6 @@
- 0,0,0.f,
- 0, 0, 0, 0, 0};
-+ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
-+ N_("RAW file reader")};
-
- int i;
-@@ -240,6 +242,4 @@
- if(opt.rawmode)
- {
-- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
-- N_("RAW file reader")};
-
- enc_opts.rate=opt.raw_samplerate;
-Index: vorbis-tools/oggenc/skeleton.h
-===================================================================
---- vorbis-tools/oggenc/skeleton.h (revision 19116)
-+++ vorbis-tools/oggenc/skeleton.h (revision 19117)
-@@ -42,5 +42,5 @@
- ogg_int64_t start_granule; /* start granule value */
- ogg_uint32_t preroll; /* preroll */
-- unsigned char granule_shift; // a 8-bit field /* 1 byte value holding the granule shift */
-+ unsigned char granule_shift; /* 1 byte value holding the granule shift */
- char *message_header_fields; /* holds all the message header fields */
- /* current total size of the message header fields, for realloc purpose, initially zero */
diff --git a/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch b/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
deleted file mode 100644
index bcddcbfd70..0000000000
--- a/gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Upstream fix for CVE-2015-6749.
-https://trac.xiph.org/ticket/2212
-
-From 04815d3e1bfae3a6cdfb2c25358a5a72b61299f7 Mon Sep 17 00:00:00 2001
-From: Mark Harris <mark.hsj@gmail.com>
-Date: Sun, 30 Aug 2015 05:54:46 -0700
-Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input
-
-Fixes #2212
----
- oggenc/audio.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/oggenc/audio.c b/oggenc/audio.c
-index 477da8c..4921fb9 100644
---- a/oggenc/audio.c
-+++ b/oggenc/audio.c
-@@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] =
- int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
- {
- int aifc; /* AIFC or AIFF? */
-- unsigned int len;
-- unsigned char *buffer;
-+ unsigned int len, readlen;
-+ unsigned char buffer[22];
- unsigned char buf2[8];
- aiff_fmt format;
- aifffile *aiff = malloc(sizeof(aifffile));
-@@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
- return 0; /* Weird common chunk */
- }
-
-- buffer = alloca(len);
--
-- if(fread(buffer,1,len,in) < len)
-+ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
-+ if(fread(buffer,1,readlen,in) < readlen ||
-+ (len > readlen && !seek_forward(in, len-readlen)))
- {
- fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
- return 0;
---
-2.5.0
-