summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-27 03:55:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-27 03:55:24 +0200
commit9df24909e252980c2393d2baaa617c30db8c9dd8 (patch)
treea32bd0d0b993f05a51bd8f49993be99c0770262d /gnu/packages/patches
parentae40e02cd68d4e0ab10690bd4e59c698df472857 (diff)
parentfdabfdbf8d5e179b2726ae69ff8aec48b0504788 (diff)
downloadguix-patches-9df24909e252980c2393d2baaa617c30db8c9dd8.tar
guix-patches-9df24909e252980c2393d2baaa617c30db8c9dd8.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libtasn1-CVE-2017-6891.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/patches/libtasn1-CVE-2017-6891.patch b/gnu/packages/patches/libtasn1-CVE-2017-6891.patch
new file mode 100644
index 0000000000..1f847ed025
--- /dev/null
+++ b/gnu/packages/patches/libtasn1-CVE-2017-6891.patch
@@ -0,0 +1,51 @@
+Fix CVE-2017-6891:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6891
+
+Patch copied from upstream source repository:
+
+https://git.savannah.gnu.org/cgit/libtasn1.git/commit/?id=5520704d075802df25ce4ffccc010ba1641bd484
+
+From 5520704d075802df25ce4ffccc010ba1641bd484 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@redhat.com>
+Date: Thu, 18 May 2017 18:03:34 +0200
+Subject: [PATCH] asn1_find_node: added safety check on asn1_find_node()
+
+This prevents a stack overflow in asn1_find_node() which
+is triggered by too long variable names in the definitions
+files. That means that applications have to deliberately
+pass a too long 'name' constant to asn1_write_value()
+and friends. Reported by Jakub Jirasek.
+
+Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
+---
+ lib/parser_aux.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/lib/parser_aux.c b/lib/parser_aux.c
+index b4a7370..976ab38 100644
+--- a/lib/parser_aux.c
++++ b/lib/parser_aux.c
+@@ -120,6 +120,9 @@ asn1_find_node (asn1_node pointer, const char *name)
+ if (n_end)
+ {
+ nsize = n_end - n_start;
++ if (nsize >= sizeof(n))
++ return NULL;
++
+ memcpy (n, n_start, nsize);
+ n[nsize] = 0;
+ n_start = n_end;
+@@ -158,6 +161,9 @@ asn1_find_node (asn1_node pointer, const char *name)
+ if (n_end)
+ {
+ nsize = n_end - n_start;
++ if (nsize >= sizeof(n))
++ return NULL;
++
+ memcpy (n, n_start, nsize);
+ n[nsize] = 0;
+ n_start = n_end;
+--
+2.13.0
+