summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-17 17:38:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-18 18:22:06 +0200
commit200762a44caaee85959b1463ee19d4138a523489 (patch)
tree67093951f637d531c7365ab74b1ecac24f831198 /gnu/packages/patches
parentf43cc4a386c2e02e888d7d5e79a4982f3fdc639a (diff)
downloadguix-patches-200762a44caaee85959b1463ee19d4138a523489.tar
guix-patches-200762a44caaee85959b1463ee19d4138a523489.tar.gz
gnu: miniupnpc: Update to 2.0.20170509.
* gnu/packages/upnp.scm (miniupnpc): Update to 2.0.20170509. [source]: Remove obsolete patch. * gnu/packages/patches/miniupnpc-CVE-2017-8798.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/miniupnpc-CVE-2017-8798.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/gnu/packages/patches/miniupnpc-CVE-2017-8798.patch b/gnu/packages/patches/miniupnpc-CVE-2017-8798.patch
deleted file mode 100644
index 24eed60af9..0000000000
--- a/gnu/packages/patches/miniupnpc-CVE-2017-8798.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-Fix CVE-2017-8798.
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8798
-http://seclists.org/oss-sec/2017/q2/247
-
-Patch copied from upstream source repository, with Changelog entry removed:
-
-https://github.com/miniupnp/miniupnp/commit/f0f1f4b22d6a98536377a1bb07e7c20e4703d229
-
-diff --git a/miniwget.c b/miniwget.c
-index 37cb47b..1eda57c 100644
---- a/miniwget.c
-+++ b/miniwget.c
-@@ -284,11 +284,12 @@ getHTTPResponse(int s, int * size, int * status_code)
- goto end_of_stream;
- }
- }
-- bytestocopy = ((int)chunksize < (n - i))?chunksize:(unsigned int)(n - i);
-+ /* it is guaranteed that (n >= i) */
-+ bytestocopy = (chunksize < (unsigned int)(n - i))?chunksize:(unsigned int)(n - i);
- if((content_buf_used + bytestocopy) > content_buf_len)
- {
- char * tmp;
-- if(content_length >= (int)(content_buf_used + bytestocopy)) {
-+ if((content_length >= 0) && ((unsigned int)content_length >= (content_buf_used + bytestocopy))) {
- content_buf_len = content_length;
- } else {
- content_buf_len = content_buf_used + bytestocopy;
-@@ -313,14 +314,15 @@ getHTTPResponse(int s, int * size, int * status_code)
- {
- /* not chunked */
- if(content_length > 0
-- && (int)(content_buf_used + n) > content_length) {
-+ && (content_buf_used + n) > (unsigned int)content_length) {
- /* skipping additional bytes */
- n = content_length - content_buf_used;
- }
- if(content_buf_used + n > content_buf_len)
- {
- char * tmp;
-- if(content_length >= (int)(content_buf_used + n)) {
-+ if(content_length >= 0
-+ && (unsigned int)content_length >= (content_buf_used + n)) {
- content_buf_len = content_length;
- } else {
- content_buf_len = content_buf_used + n;
-@@ -340,7 +342,7 @@ getHTTPResponse(int s, int * size, int * status_code)
- }
- }
- /* use the Content-Length header value if available */
-- if(content_length > 0 && (int)content_buf_used >= content_length)
-+ if(content_length > 0 && content_buf_used >= (unsigned int)content_length)
- {
- #ifdef DEBUG
- printf("End of HTTP content\n");