summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorIvan Vilata-i-Balaguer <ivan@selidor.net>2019-12-15 14:22:08 -0500
committerEfraim Flashner <efraim@flashner.co.il>2019-12-19 13:03:04 +0200
commita21d9b8d5c15f200f3c71cfb86207dbefcff6c80 (patch)
treec40458fe9894406663ec939eb530e7eeffea425a /gnu/packages/patches
parent003fcf23d9bd2f8014f5b4fe931b994bba5b8b28 (diff)
downloadguix-patches-a21d9b8d5c15f200f3c71cfb86207dbefcff6c80.tar
guix-patches-a21d9b8d5c15f200f3c71cfb86207dbefcff6c80.tar.gz
gnu: mumble: Update to 1.3.0.
* gnu/packages/telephony.scm (mumble): Update to 1.3.0. [source]: Remove patch. Update snippet. [build-system]: Switch to qt-build-system. [arguments]: Update custom 'configure phase. Add custom phase to disable murmur ice. [inputs]: Remove protobuf-3.5, libx11, qt-4, alsa-lib. Add protobuf, mesa, qtbase, qtsvg. [native-inputs]: Add python, qttools. [license]: Update license info. * gnu/packages/patches/mumble-1.2.19-abs.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mumble-1.2.19-abs.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/patches/mumble-1.2.19-abs.patch b/gnu/packages/patches/mumble-1.2.19-abs.patch
deleted file mode 100644
index 683325f4bc..0000000000
--- a/gnu/packages/patches/mumble-1.2.19-abs.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From ea861fe86743c8402bbad77d8d1dd9de8dce447e Mon Sep 17 00:00:00 2001
-From: Mikkel Krautz <mikkel@krautz.dk>
-Date: Fri, 29 Dec 2017 14:47:25 +0100
-Subject: [PATCH] AudioOutput: do not use non-existant template version of
- std::abs.
-
-This change fixes AudioOutput to use the float overload of std::abs:
-
- float std::abs(float);
-
-instead of a non-existant template version (for newer Boost 1.66).
-
-Fixes mumble-voip/mumble#3281
-
----
- src/mumble/AudioOutput.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/mumble/AudioOutput.cpp b/src/mumble/AudioOutput.cpp
-index cbe0c0e2b..7a0a5e2ab 100644
---- a/src/mumble/AudioOutput.cpp
-+++ b/src/mumble/AudioOutput.cpp
-@@ -437,7 +437,7 @@ bool AudioOutput::mix(void *outbuff, unsigned int nsamp) {
- top[2] = 0.0f;
- }
-
-- if (std::abs<float>(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
-+ if (std::abs(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
- // Not perpendicular. Assume Y up and rotate 90 degrees.
-
- float azimuth = 0.0f;