summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-04-07 19:21:28 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-23 10:29:35 +1000
commit98593f9f51c8f6e3c2208d8443fdf08cf4d633bb (patch)
treee772fee04adedb87fa1ff5ff42fbf91c38f99710 /gnu/packages/patches
parent4ab1644049ad2d1cf7a997dfa910a4d7d646e49f (diff)
downloadguix-patches-98593f9f51c8f6e3c2208d8443fdf08cf4d633bb.tar
guix-patches-98593f9f51c8f6e3c2208d8443fdf08cf4d633bb.tar.gz
gnu: bcftools: Update to 1.4.1.
* gnu/packages/bioinformatics.scm (bcftools): Update to 1.4.1. [arguments]: Move Makefile modifications from here ... [source]: ... to added patch. Adjust patch for update to 1.4. * gnu/packages/patches/bcftools-fix-makefile.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bcftools-fix-makefile.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/bcftools-fix-makefile.patch b/gnu/packages/patches/bcftools-fix-makefile.patch
new file mode 100644
index 0000000000..614f5fd6bd
--- /dev/null
+++ b/gnu/packages/patches/bcftools-fix-makefile.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index edd2c4a..73b25ea 100644
+--- a/Makefile
++++ b/Makefile
+@@ -30,8 +30,8 @@ all: $(PROG) $(TEST_PROG)
+
+ # Adjust $(HTSDIR) to point to your top-level htslib directory
+ HTSDIR = htslib-1.4.1
+-include $(HTSDIR)/htslib.mk
+-include $(HTSDIR)/htslib_static.mk
++#include $(HTSDIR)/htslib.mk
++#include $(HTSDIR)/htslib_static.mk
+ HTSLIB = $(HTSDIR)/libhts.a
+ BGZIP = $(HTSDIR)/bgzip
+ TABIX = $(HTSDIR)/tabix
+@@ -73,7 +73,7 @@ GSL_LIBS =
+ ifdef USE_GPL
+ EXTRA_CPPFLAGS += -DUSE_GPL
+ OBJS += polysomy.o peakfit.o
+- GSL_LIBS = -lgsl -lcblas
++ GSL_LIBS = -lgsl -lgslcblas
+ endif
+
+ prefix = /usr/local
+@@ -217,7 +217,7 @@ test/test-regidx.o: test/test-regidx.c regidx.h
+ test/test-regidx: test/test-regidx.o regidx.o $(HTSLIB)
+ $(CC) $(ALL_LDFLAGS) -o $@ $^ $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(ALL_LIBS)
+
+-bcftools: $(HTSLIB) $(OBJS)
++bcftools: $(OBJS)
+ $(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(GSL_LIBS) $(ALL_LIBS)
+
+ doc/bcftools.1: doc/bcftools.txt