summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-08-01 15:19:38 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-01 15:32:07 +0200
commit04b6d6f7f7a73e39dcff1e2bca3113ea567e2944 (patch)
treec9f9ab3a8c32f7decd9c5b80cfc3f0894d95df6d /gnu/packages/patches
parent12235a124f7fc56d9cd4eaf76a453cf55d3026ea (diff)
downloadguix-patches-04b6d6f7f7a73e39dcff1e2bca3113ea567e2944.tar
guix-patches-04b6d6f7f7a73e39dcff1e2bca3113ea567e2944.tar.gz
gnu: guile-ssh: Update to 0.11.2.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.11.2. [source]: Remove 'patches', 'modules', and 'snippet'. * gnu/packages/patches/guile-ssh-channel-finalization.patch, gnu/packages/patches/guile-ssh-double-free.patch, gnu/packages/patches/guile-ssh-rexec-bug.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-ssh-channel-finalization.patch28
-rw-r--r--gnu/packages/patches/guile-ssh-double-free.patch37
-rw-r--r--gnu/packages/patches/guile-ssh-rexec-bug.patch16
3 files changed, 0 insertions, 81 deletions
diff --git a/gnu/packages/patches/guile-ssh-channel-finalization.patch b/gnu/packages/patches/guile-ssh-channel-finalization.patch
deleted file mode 100644
index 54b5055a20..0000000000
--- a/gnu/packages/patches/guile-ssh-channel-finalization.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Avoid asynchronous channel finalization, which could lead to segfaults due to
-libssh not being thread-safe: <https://bugs.gnu.org/26976>.
-
---- guile-ssh-0.11.0/modules/ssh/dist/node.scm 2017-06-13 14:37:44.861671297 +0200
-+++ guile-ssh-0.11.0/modules/ssh/dist/node.scm 2017-06-13 14:38:02.841580565 +0200
-@@ -391,11 +391,18 @@ listens on an expected port, return #f o
- "Evaluate QUOTED-EXP on the node and return the evaluated result."
- (let ((repl-channel (node-open-rrepl node)))
- (rrepl-skip-to-prompt repl-channel)
-- (call-with-values (lambda () (rrepl-eval repl-channel quoted-exp))
-- (lambda vals
-- (and (node-stop-repl-server? node)
-+ (dynamic-wind
-+ (const #t)
-+ (lambda ()
-+ (rrepl-eval repl-channel quoted-exp))
-+ (lambda ()
-+ (when (node-stop-repl-server? node)
- (node-stop-server node))
-- (apply values vals)))))
-+
-+ ;; Close REPL-CHANNEL right away to prevent finalization from
-+ ;; happening in another thread at the wrong time (see
-+ ;; <https://bugs.gnu.org/26976>.)
-+ (close-port repl-channel)))))
-
- (define (node-eval-1 node quoted-exp)
- "Evaluate QUOTED-EXP on the node and return the evaluated result. The
diff --git a/gnu/packages/patches/guile-ssh-double-free.patch b/gnu/packages/patches/guile-ssh-double-free.patch
deleted file mode 100644
index 9692b81d39..0000000000
--- a/gnu/packages/patches/guile-ssh-double-free.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Fix a double-free or use-after-free issue with Guile-SSH used
-with Guile 2.2. See <https://bugs.gnu.org/26976>.
-
-diff --git a/libguile-ssh/channel-type.c b/libguile-ssh/channel-type.c
-index 3dd641f..0839854 100644
---- a/libguile-ssh/channel-type.c
-+++ b/libguile-ssh/channel-type.c
-@@ -229,10 +229,11 @@ ptob_close (SCM channel)
- ssh_channel_free (ch->ssh_channel);
- }
-
-+ SCM_SETSTREAM (channel, NULL);
-+
- #if USING_GUILE_BEFORE_2_2
- scm_gc_free (pt->write_buf, pt->write_buf_size, "port write buffer");
- scm_gc_free (pt->read_buf, pt->read_buf_size, "port read buffer");
-- SCM_SETSTREAM (channel, NULL);
-
- return 0;
- #endif
-diff --git a/libguile-ssh/sftp-file-type.c b/libguile-ssh/sftp-file-type.c
-index 8879924..f87cf03 100644
---- a/libguile-ssh/sftp-file-type.c
-+++ b/libguile-ssh/sftp-file-type.c
-@@ -224,10 +224,11 @@ ptob_close (SCM sftp_file)
- sftp_close (fd->file);
- }
-
-+ SCM_SETSTREAM (sftp_file, NULL);
-+
- #if USING_GUILE_BEFORE_2_2
- scm_gc_free (pt->write_buf, pt->write_buf_size, "port write buffer");
- scm_gc_free (pt->read_buf, pt->read_buf_size, "port read buffer");
-- SCM_SETSTREAM (sftp_file, NULL);
-
- return 1;
- #endif
diff --git a/gnu/packages/patches/guile-ssh-rexec-bug.patch b/gnu/packages/patches/guile-ssh-rexec-bug.patch
deleted file mode 100644
index 363fea38c9..0000000000
--- a/gnu/packages/patches/guile-ssh-rexec-bug.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix a bug whereby 'node-guile-version' would pass a node instead of
-a session to 'rexec'.
-
-diff --git a/modules/ssh/dist/node.scm b/modules/ssh/dist/node.scm
-index 9c065c7..29a3906 100644
---- a/modules/ssh/dist/node.scm
-+++ b/modules/ssh/dist/node.scm
-@@ -411,7 +411,8 @@ procedure returns the 1st evaluated value if multiple values were returned."
- "Get Guile version installed on a NODE, return the version string. Return
- #f if Guile is not installed."
- (receive (result rc)
-- (rexec node "which guile > /dev/null && guile --version")
-+ (rexec (node-session node)
-+ "which guile > /dev/null && guile --version")
- (and (zero? rc)
- (car result))))