summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-28 20:20:52 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-28 20:20:52 +0200
commitba948b4fa0a088f42815aa104e651c9d14d8a1ba (patch)
tree04553907e90cde6ff3fef0e9e4ccb762531f9553 /gnu/packages/patches
parentc69fe8306d7fa69fa67c31b296ae25353f73a2a0 (diff)
downloadguix-patches-ba948b4fa0a088f42815aa104e651c9d14d8a1ba.tar
guix-patches-ba948b4fa0a088f42815aa104e651c9d14d8a1ba.tar.gz
gnu: soprano: Add input clucene.
* gnu/packages/rdf.scm (soprano): Add input clucene and patch the cmake file looking for it. * gnu/packages/patches/soprano-find-clucene.patch: New file. * gnu-system.am (dist_patch_DATA): Register the patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/soprano-find-clucene.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/soprano-find-clucene.patch b/gnu/packages/patches/soprano-find-clucene.patch
new file mode 100644
index 0000000000..cc2707853a
--- /dev/null
+++ b/gnu/packages/patches/soprano-find-clucene.patch
@@ -0,0 +1,15 @@
+Search for clucene include file in the clucene include directory.
+
+diff -u -r soprano-2.9.4.orig/cmake/modules/FindCLucene.cmake soprano-2.9.4/cmake/modules/FindCLucene.cmake
+--- soprano-2.9.4.orig/cmake/modules/FindCLucene.cmake 2013-10-09 19:22:28.000000000 +0200
++++ soprano-2.9.4/cmake/modules/FindCLucene.cmake 2014-04-28 20:08:11.000000000 +0200
+@@ -77,7 +77,8 @@
+
+ get_filename_component(TRIAL_LIBRARY_DIR ${CLUCENE_LIBRARY} PATH)
+ find_path(CLUCENE_LIBRARY_DIR
+- NAMES CLucene/clucene-config.h PATHS ${TRIAL_LIBRARY_DIR} ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} NO_DEFAULT_PATH)
++ NAMES CLucene/clucene-config.h PATHS ${TRIAL_LIBRARY_DIR} ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} ${CLUCENE_INCLUDE_DIR} NO_DEFAULT_PATH)
++message (STATUS "XXX ${CLUCENE_LIBRARY_DIR}")
+ if(CLUCENE_LIBRARY_DIR)
+ message(STATUS "Found CLucene library dir: ${CLUCENE_LIBRARY_DIR}")
+ file(READ ${CLUCENE_LIBRARY_DIR}/CLucene/clucene-config.h CLCONTENT)