summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-04-30 14:01:43 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-01 15:27:30 -0500
commitb9100e2f11a6735d37bb256ffecb947f9b7ce31f (patch)
treec2677f90ad8d7cf01e0ee4ed06ae6ec130a9052e /gnu/packages/patches
parent3da5dca34c39b209787bc583c16fbe76333c2f4e (diff)
downloadguix-patches-b9100e2f11a6735d37bb256ffecb947f9b7ce31f.tar
guix-patches-b9100e2f11a6735d37bb256ffecb947f9b7ce31f.tar.gz
gnu: Add petsc
* gnu/packages/maths.scm (petsc): New variable. (petsc-complex): New variable. * gnu/packages/patches/petsc-fix-threadcomm.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/petsc-fix-threadcomm.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/petsc-fix-threadcomm.patch b/gnu/packages/patches/petsc-fix-threadcomm.patch
new file mode 100644
index 0000000000..3ef4f2d83d
--- /dev/null
+++ b/gnu/packages/patches/petsc-fix-threadcomm.patch
@@ -0,0 +1,15 @@
+Fix "error: unknown type name 'cpu_set_t'". Patch submitted upstream
+http://lists.mcs.anl.gov/pipermail/petsc-dev/2014-May/015345.html
+
+--- a/src/sys/threadcomm/impls/openmp/tcopenmp.c 2014-03-13 21:47:22.000000000 -0500
++++ b/src/sys/threadcomm/impls/openmp/tcopenmp.c 2014-04-02 14:44:57.185170151 -0500
+@@ -1,6 +1,9 @@
+ #define PETSC_DESIRE_FEATURE_TEST_MACROS
+ #include <../src/sys/threadcomm/impls/openmp/tcopenmpimpl.h>
+ #include <omp.h>
++#if defined(PETSC_HAVE_SCHED_CPU_SET_T)
++#include <sched.h>
++#endif
+
+ PetscErrorCode PetscThreadCommGetRank_OpenMP(PetscInt *trank)
+ {