summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 22:53:21 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 23:01:15 +0100
commitf862d7fb8d3656e7e0ec8ff5ef97db8e46536e93 (patch)
tree786b5616ee35090518d2e2b7fbde0f3ebe503155 /gnu/packages/patches
parent84c3aafb5a18ad278bbb36df7b70849fe05789c8 (diff)
downloadguix-patches-f862d7fb8d3656e7e0ec8ff5ef97db8e46536e93.tar
guix-patches-f862d7fb8d3656e7e0ec8ff5ef97db8e46536e93.tar.gz
gnu: network-manager: Build with Meson 0.60.
This is another way to address <https://github.com/mesonbuild/meson/issues/9492> as suggested by Nirbheek Chauhan and Paolo Bonzini. * gnu/packages/patches/network-manager-meson.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (network-manager)[source]: Use it. [arguments]: Remove #:meson.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/network-manager-meson.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/network-manager-meson.patch b/gnu/packages/patches/network-manager-meson.patch
new file mode 100644
index 0000000000..1056d40ede
--- /dev/null
+++ b/gnu/packages/patches/network-manager-meson.patch
@@ -0,0 +1,21 @@
+Since libnm-wwan.so is not just a loadable module but also a shared library
+that some plugin links against, build it as a shared library while avoiding
+'-Wl,--no-undefined':
+
+ https://github.com/mesonbuild/meson/issues/9492#issuecomment-973117289
+
+diff --git a/src/core/devices/wwan/meson.build b/src/core/devices/wwan/meson.build
+index 37ef738..18ac54f 100644
+--- a/src/core/devices/wwan/meson.build
++++ b/src/core/devices/wwan/meson.build
+@@ -4,8 +4,9 @@ wwan_inc = include_directories('.')
+
+ linker_script = join_paths(meson.current_source_dir(), 'libnm-wwan.ver')
+
+-libnm_wwan = shared_module(
++libnm_wwan = shared_library(
+ 'nm-wwan',
++ override_options: ['b_lundef=false'],
+ sources: files(
+ 'nm-service-providers.c',
+ 'nm-modem-broadband.c',