summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 13:59:30 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:58 +0200
commit2069238cb35fee5f8da1dd8fab6df4749bee135b (patch)
treecf82b92a41db8c7516fd5ce185a625f9ab435cb2 /gnu/packages/patches
parentd9b8cfd6c649fb246f7fdf2dc283c27c4afae100 (diff)
downloadguix-patches-2069238cb35fee5f8da1dd8fab6df4749bee135b.tar
guix-patches-2069238cb35fee5f8da1dd8fab6df4749bee135b.tar.gz
gnu: Add aws-c-compression.
* gnu/packages/c.scm (aws-c-compression): New variable. * gnu/packages/patches/aws-c-compression-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/aws-c-compression-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-compression-cmake-prefix.patch b/gnu/packages/patches/aws-c-compression-cmake-prefix.patch
new file mode 100644
index 0000000000..eefae19c4a
--- /dev/null
+++ b/gnu/packages/patches/aws-c-compression-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,6 +5,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()