summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 21:23:07 +0100
commitaccd5f996e2cfda656dee3cba97de5fd3cec3ad9 (patch)
treec1ed250c307bde1adc11217016714d69a236b6df /gnu/packages/patches
parent8ceebf8fa6d513e86e3292727678b0d21b885d08 (diff)
downloadguix-patches-accd5f996e2cfda656dee3cba97de5fd3cec3ad9.tar
guix-patches-accd5f996e2cfda656dee3cba97de5fd3cec3ad9.tar.gz
gnu: python-ipython: Update to 4.0.0.
* gnu/packages/python.scm (python-ipython): Update to 4.0.0. [inputs]: Keep only "readline" and "which"; move the remaining inputs to propagated-inputs, except for "python-requests" and "python-nose" which are moved to native-inputs. [propagated-inputs]: Add "python-pexpect", "python-pickleshare", "python-simplegeneric", "python-traitlets", "python-ipykernel". [native-inputs]: Add "python-testpath". [arguments]: Enable building of HTML documentation. [source]: Remove patch. * gnu/packages/patches/python-ipython-inputhook-ctype.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-ipython-inputhook-ctype.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/patches/python-ipython-inputhook-ctype.patch b/gnu/packages/patches/python-ipython-inputhook-ctype.patch
deleted file mode 100644
index c77e310542..0000000000
--- a/gnu/packages/patches/python-ipython-inputhook-ctype.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 04c5d358c7ab74d3ddab4f7662e539393d8604c6 Mon Sep 17 00:00:00 2001
-From: Lucretiel <Lucretiel@users.noreply.github.com>
-Date: Wed, 13 May 2015 13:12:43 -0400
-Subject: [PATCH] register now checks for missing ctypes
-
-If ctypes is None, then no input hooks may be registered; `InputHookManager.register` skips registration of input hook classes. Also updated `__init__` to no longer skip creating the instance attributes, to prevent AttributeError exceptions at load time.
----
- IPython/lib/inputhook.py | 13 +++++++------
- 1 file changed, 7 insertions(+), 6 deletions(-)
-
-diff --git a/IPython/lib/inputhook.py b/IPython/lib/inputhook.py
-index 4ae2cb3..6578365 100644
---- a/IPython/lib/inputhook.py
-+++ b/IPython/lib/inputhook.py
-@@ -107,8 +107,8 @@ class InputHookManager(object):
- def __init__(self):
- if ctypes is None:
- warn("IPython GUI event loop requires ctypes, %gui will not be available")
-- return
-- self.PYFUNC = ctypes.PYFUNCTYPE(ctypes.c_int)
-+ else:
-+ self.PYFUNC = ctypes.PYFUNCTYPE(ctypes.c_int)
- self.guihooks = {}
- self.aliases = {}
- self.apps = {}
-@@ -197,10 +197,11 @@ def enable(self, app=None):
- ...
- """
- def decorator(cls):
-- inst = cls(self)
-- self.guihooks[toolkitname] = inst
-- for a in aliases:
-- self.aliases[a] = toolkitname
-+ if ctypes is not None:
-+ inst = cls(self)
-+ self.guihooks[toolkitname] = inst
-+ for a in aliases:
-+ self.aliases[a] = toolkitname
- return cls
- return decorator
-