summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-15 14:59:49 +0100
committerMarius Bakke <marius@gnu.org>2022-01-15 15:18:31 +0100
commitbd4f314bbacaaa56751be3a4769f2082be747d24 (patch)
treea33394ed13b5ffc74cecb615f1f1a318b098c8c0 /gnu/packages/patches
parent98af365b6842879ac5d7e232dc9bb62903630f46 (diff)
downloadguix-patches-bd4f314bbacaaa56751be3a4769f2082be747d24.tar
guix-patches-bd4f314bbacaaa56751be3a4769f2082be747d24.tar.gz
gnu: tree: Fix problem with no output when fd3 is present.
* gnu/packages/patches/tree-disable-stddata.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/admin.scm (tree)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/tree-disable-stddata.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/tree-disable-stddata.patch b/gnu/packages/patches/tree-disable-stddata.patch
new file mode 100644
index 0000000000..52ca6e25f4
--- /dev/null
+++ b/gnu/packages/patches/tree-disable-stddata.patch
@@ -0,0 +1,16 @@
+Tree 2.0.0 and later will write its output in JSON format on fd3 if
+present, instead of the requested output on fd1, which breaks e.g.
+'password-store' tests. Disable for now; upstream has been notified.
+
+diff --git a/tree.c b/tree.c
+--- a/tree.c
++++ b/tree.c
+@@ -133,7 +133,7 @@ int main(int argc, char **argv)
+ mb_cur_max = 1;
+ #endif
+
+-#ifdef __linux__
++#if 0
+ // Output JSON automatically to "stddata" if present:
+ if (fcntl(STDDATA_FILENO, F_GETFD) >= 0) {
+ Jflag = noindent = TRUE;