summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2018-04-11 09:54:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-04-17 00:08:45 +0200
commitd09e31bdf66b12c9756aede3b306909a9b0235f4 (patch)
treea78eee38fec055bfd16f76a0eca17719636e10ce /gnu/packages/patches
parent237587f1e07f79d1d39212e05f9548ddc6856387 (diff)
downloadguix-patches-d09e31bdf66b12c9756aede3b306909a9b0235f4.tar
guix-patches-d09e31bdf66b12c9756aede3b306909a9b0235f4.tar.gz
gnu: libmygpo-qt: Update to 1.1.0.
* gnu/packages/music.scm (libmygpo-qt): Update to 1.1.0. [source]: Remove 'patches'. [arguments]: Do not set BUILD_WITH_QT4=OFF, it is the default. * gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch b/gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch
deleted file mode 100644
index c457d592cc..0000000000
--- a/gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From ebe2323727f8d646590245b0bf06dbc92b5808d6 Mon Sep 17 00:00:00 2001
-From: Golubev Alexander <fatzer2@gmail.com>
-Date: Tue, 20 Sep 2016 15:33:30 +0400
-Subject: [PATCH] JsonCreatorTest failed due to extra space
-
-JsonCreatorTest failed with next message:
-```
-********* Start testing of mygpo::JsonCreatorTest *********
-Config: Using QTest library 4.8.6, Qt 4.8.6
-PASS : mygpo::JsonCreatorTest::initTestCase()
-PASS : mygpo::JsonCreatorTest::testAddRemoveSubsToJSON()
-PASS : mygpo::JsonCreatorTest::testSaveSettingsToJSON()
-FAIL! : mygpo::JsonCreatorTest::testEpisodeActionListToJSON() Compared values are not the same
- Actual (outString2): [{"action":"download","device":"device1","episode":"http://episode.url","podcast":"http://podcast.url","timestamp":"1998-01-01T00:01:02"},{"action":"delete","device":"device3","episode":"http://episode2.url","podcast":"http://podcast2.url","timestamp":"1920-01-01T12:01:02"},{"action":"new","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","timestamp":"1998-01-01T00:01:02"},{"action":"play","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","timestamp":"1920-01-01T12:01:02"},{"action":"play","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","position":123,"started":10,"timestamp":"1998-01-01T00:01:02","total":321},{"action":"play","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","position":10,"timestamp":"1998-01-01T00:01:02"}]
- Expected (expected2): [{"action":"download","device":"device1","episode":"http://episode.url","podcast":"http:
- Loc: [/var/tmp/portage/media-libs/libmygpo-qt-1.0.9-r1/work/libmygpo-qt-1.0.9/tests/JsonCreatorTest.cpp(138)]
-PASS : mygpo::JsonCreatorTest::testRenameDeviceStringToJSON()
-PASS : mygpo::JsonCreatorTest::testDeviceSynchronizationListsToJSON()
-PASS : mygpo::JsonCreatorTest::cleanupTestCase()
-Totals: 6 passed, 1 failed, 0 skipped
-********* Finished testing of mygpo::JsonCreatorTest *********
-```
-
-This was caused by extra space in the expected string.
----
- tests/JsonCreatorTest.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/JsonCreatorTest.cpp b/tests/JsonCreatorTest.cpp
-index b15b006..feb03d5 100644
---- a/tests/JsonCreatorTest.cpp
-+++ b/tests/JsonCreatorTest.cpp
-@@ -133,7 +133,7 @@ void JsonCreatorTest::testEpisodeActionListToJSON()
-
- output = JsonCreator::episodeActionListToJSON(episodeActions);
- QString outString2 = QString::fromLatin1( output ).replace( QLatin1String(" "), QLatin1String("") );
-- QString expected2( QLatin1String( "[{\"action\":\"download\",\"device\":\"device1\",\"episode\":\"http://episode.url\",\"podcast\":\"http://podcast.url\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"delete\",\"device\":\"device3\",\"episode\":\"http://episode2.url\",\"podcast\":\"http://podcast2.url\",\"timestamp\":\"1920-01-01T12:01:02\"},{\"action\":\"new\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1920-01-01T12:01:02\" },{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":123,\"started\":10,\"timestamp\":\"1998-01-01T00:01:02\",\"total\":321},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":10,\"timestamp\":\"1998-01-01T00:01:02\"}]" ) );
-+ QString expected2( QLatin1String( "[{\"action\":\"download\",\"device\":\"device1\",\"episode\":\"http://episode.url\",\"podcast\":\"http://podcast.url\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"delete\",\"device\":\"device3\",\"episode\":\"http://episode2.url\",\"podcast\":\"http://podcast2.url\",\"timestamp\":\"1920-01-01T12:01:02\"},{\"action\":\"new\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1920-01-01T12:01:02\"},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":123,\"started\":10,\"timestamp\":\"1998-01-01T00:01:02\",\"total\":321},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":10,\"timestamp\":\"1998-01-01T00:01:02\"}]" ) );
-
- QCOMPARE(outString2, expected2 );
- }