summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-29 13:57:56 -0400
committerLeo Famulari <leo@famulari.name>2016-05-29 14:02:08 -0400
commit65da8dd01ed02b8bf4499b175a49345633f56451 (patch)
tree1901bbc24a4dcba21aec3f7a963f5f4cd0c8d644 /gnu/packages/patches
parent41019e9f2ae2a997b39a7091f0ef08670a5f3d7d (diff)
downloadguix-patches-65da8dd01ed02b8bf4499b175a49345633f56451.tar
guix-patches-65da8dd01ed02b8bf4499b175a49345633f56451.tar.gz
gnu: rpm: Fix CVE-2014-8118.
* gnu/packages/patches/rpm-CVE-2014-8118.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/package-management.scm (rpm): Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rpm-CVE-2014-8118.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/rpm-CVE-2014-8118.patch b/gnu/packages/patches/rpm-CVE-2014-8118.patch
new file mode 100644
index 0000000000..5fdb0f0eb2
--- /dev/null
+++ b/gnu/packages/patches/rpm-CVE-2014-8118.patch
@@ -0,0 +1,25 @@
+Fix CVE-2014-8118 (integer overflow allowing arbitrary remote code
+execution via crafted CPIO header).
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8118
+
+Source:
+https://bugzilla.redhat.com/attachment.cgi?id=962159&action=diff
+
+Adopted by Debian:
+http://anonscm.debian.org/cgit/collab-maint/rpm.git/plain/debian/patches/CVE-2014-8118.patch
+
+diff --git a/lib/cpio.c b/lib/cpio.c
+index 253ff0f..600633a 100644
+--- a/lib/cpio.c
++++ b/lib/cpio.c
+@@ -399,6 +399,9 @@ int rpmcpioHeaderRead(rpmcpio_t cpio, char ** path, int * fx)
+
+ GET_NUM_FIELD(hdr.filesize, fsize);
+ GET_NUM_FIELD(hdr.namesize, nameSize);
++ if (nameSize <= 0 || nameSize > 4096) {
++ return RPMERR_BAD_HEADER;
++ }
+
+ char name[nameSize + 1];
+ read = Fread(name, nameSize, 1, cpio->fd);