summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-25 17:35:27 +0000
committerLudovic Courtès <ludo@gnu.org>2021-01-26 23:32:54 +0100
commit94cf36763491cfd7155a058e0354da5a422a07b2 (patch)
tree6508d8b86071b0e2e3fa076d1a94c2dc4ff82392 /gnu/packages/patches
parentced3d5cbf99eac429a45e33191335ec0662f1df3 (diff)
downloadguix-patches-94cf36763491cfd7155a058e0354da5a422a07b2.tar
guix-patches-94cf36763491cfd7155a058e0354da5a422a07b2.tar.gz
gnu: boost: Patch transitive linking bug.
* gnu/packages/patches/boost-fix-transitive-linking.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/boost.scm (boost)[source]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/boost-fix-transitive-linking.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/boost-fix-transitive-linking.patch b/gnu/packages/patches/boost-fix-transitive-linking.patch
new file mode 100644
index 0000000000..a42feab109
--- /dev/null
+++ b/gnu/packages/patches/boost-fix-transitive-linking.patch
@@ -0,0 +1,16 @@
+Patch from https://github.com/boostorg/boost_install/issues/47
+which should be included in the Boost 1.76 release.
+
+This patch prevents CMake from explicitly linking against Boost dependencies
+when building against the shared Boost libraries.
+--- a/tools/boost_install/boost-install.jam
++++ b/tools/boost_install/boost-install.jam
+@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * : properties * )
+
+ .info " deps3=" $(deps3) ;
+
+- if $(deps3)
++ if $(deps3) && $(link) = static
+ {
+ print.text
+