summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-06-07 09:31:03 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-06-07 09:33:57 +0200
commitdbe607925a32f0dfc47550a4ddc3ec15bcb1115e (patch)
treea6a9efdb0606dcccb0872ee0ee0d15e7958331c7 /gnu/packages/patches
parent4604d43c0e438107d834fb68ea46130bbfc5ec9f (diff)
downloadguix-patches-dbe607925a32f0dfc47550a4ddc3ec15bcb1115e.tar
guix-patches-dbe607925a32f0dfc47550a4ddc3ec15bcb1115e.tar.gz
gnu: xpra: Update to 4.2.
Fixes <https://issues.guix.gnu.org/issue/48890>. * gnu/packages/xorg.scm (xpra): Update to 4.2. [source]: Switch to ".tar.gz" archive and update patch file. [native-inputs]: Add pandoc. [arguments]: Adjust custom 'fix-paths phase for changes in source. * gnu/packages/patches/xpra-4.2-systemd-run.patch: Adapt to new version and rename file. * gnu/local.mk (dist_patch_DATA): Rename file. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xpra-4.0.1-systemd-run.patch34
-rw-r--r--gnu/packages/patches/xpra-4.2-systemd-run.patch45
2 files changed, 45 insertions, 34 deletions
diff --git a/gnu/packages/patches/xpra-4.0.1-systemd-run.patch b/gnu/packages/patches/xpra-4.0.1-systemd-run.patch
deleted file mode 100644
index 1ea11830a5..0000000000
--- a/gnu/packages/patches/xpra-4.0.1-systemd-run.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Disable systemd-run if the command is not found.
-
-diff -Naur xpra-4.0.1/xpra/scripts/main.py xpra-4.0.1.patched/xpra/scripts/main.py
---- xpra-4.0.1/xpra/scripts/main.py 2020-05-17 18:12:15.000000000 +0200
-+++ xpra-4.0.1.patched/xpra/scripts/main.py 2020-06-01 12:12:18.500257507 +0200
-@@ -312,16 +312,18 @@
- if not is_systemd_pid1():
- return False
- #test it:
-- cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
-- proc = Popen(cmd, stdin=None, stdout=None, stderr=None, shell=False)
-- r = pollwait(proc, timeout=1)
-- if r is None:
-- try:
-- proc.terminate()
-- except Exception:
-- pass
-- return r==0
--
-+ try:
-+ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
-+ proc = Popen(cmd, stdin=None, stdout=None, stderr=None, shell=False)
-+ r = pollwait(proc, timeout=1)
-+ if r is None:
-+ try:
-+ proc.terminate()
-+ except Exception:
-+ pass
-+ return r==0
-+ except FileNotFoundError:
-+ return False
-
- def run_mode(script_file, error_cb, options, args, mode, defaults):
- #configure default logging handler:
diff --git a/gnu/packages/patches/xpra-4.2-systemd-run.patch b/gnu/packages/patches/xpra-4.2-systemd-run.patch
new file mode 100644
index 0000000000..8dfd9c82f0
--- /dev/null
+++ b/gnu/packages/patches/xpra-4.2-systemd-run.patch
@@ -0,0 +1,45 @@
+Disable systemd-run if the command is not found.
+
+diff -ru xpra-4.2~/xpra/scripts/main.py xpra-4.2/xpra/scripts/main.py
+--- xpra-4.2~/xpra/scripts/main.py 2021-06-06 08:51:13.756815842 -0700
++++ xpra-4.2/xpra/scripts/main.py 2021-06-06 16:07:13.371024486 -0700
+@@ -331,23 +331,26 @@
+ if not is_systemd_pid1():
+ return False # pragma: no cover
+ #test it:
+- cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
+- proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
+ try:
+- proc.communicate(timeout=2)
+- r = proc.returncode
+- except TimeoutExpired: # pragma: no cover
+- r = None
+- if r is None:
++ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
++ proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
+ try:
+- proc.terminate()
+- except Exception:
+- pass
+- try:
+- proc.communicate(timeout=1)
++ proc.communicate(timeout=2)
++ r = proc.returncode
+ except TimeoutExpired: # pragma: no cover
+ r = None
+- return r==0
++ if r is None:
++ try:
++ proc.terminate()
++ except Exception:
++ pass
++ try:
++ proc.communicate(timeout=1)
++ except TimeoutExpired: # pragma: no cover
++ r = None
++ return r==0
++ except FileNotFoundError:
++ return False
+
+
+ def run_mode(script_file, error_cb, options, args, mode, defaults):