summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
commit9dea3f101f252331c049c03f501398a5ec837ba9 (patch)
tree61d683a9fae3e147332d07fef207c1ddf51fc301 /gnu/packages/patches
parent7f0af119a1e3ea9d0ae53811b619437b3e942702 (diff)
parent620669fd17306c2edb21c64a99fa47160fefb319 (diff)
downloadguix-patches-9dea3f101f252331c049c03f501398a5ec837ba9.tar
guix-patches-9dea3f101f252331c049c03f501398a5ec837ba9.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/cups.scm gnu/packages/python-web.scm gnu/packages/web.scm guix/build/maven/pom.scm
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cups-CVE-2020-10001.patch47
-rw-r--r--gnu/packages/patches/linkchecker-tests-require-network.patch182
-rw-r--r--gnu/packages/patches/tlf-support-hamlib-4.2+.patch66
-rw-r--r--gnu/packages/patches/widelands-system-wide_minizip.patch44
4 files changed, 129 insertions, 210 deletions
diff --git a/gnu/packages/patches/cups-CVE-2020-10001.patch b/gnu/packages/patches/cups-CVE-2020-10001.patch
new file mode 100644
index 0000000000..1b16c7d97c
--- /dev/null
+++ b/gnu/packages/patches/cups-CVE-2020-10001.patch
@@ -0,0 +1,47 @@
+From efbea1742bd30f842fbbfb87a473e5c84f4162f9 Mon Sep 17 00:00:00 2001
+From: Michael R Sweet <msweet@msweet.org>
+Date: Mon, 1 Feb 2021 15:02:32 -0500
+Subject: [PATCH] Fix a buffer (read) overflow in ippReadIO (CVE-2020-10001)
+
+---
+
+diff --git a/cups/ipp.c b/cups/ipp.c
+index 3d529346c..adbb26fba 100644
+--- a/cups/ipp.c
++++ b/cups/ipp.c
+@@ -2866,7 +2866,8 @@ ippReadIO(void *src, /* I - Data source */
+ unsigned char *buffer, /* Data buffer */
+ string[IPP_MAX_TEXT],
+ /* Small string buffer */
+- *bufptr; /* Pointer into buffer */
++ *bufptr, /* Pointer into buffer */
++ *bufend; /* End of buffer */
+ ipp_attribute_t *attr; /* Current attribute */
+ ipp_tag_t tag; /* Current tag */
+ ipp_tag_t value_tag; /* Current value tag */
+@@ -3441,6 +3442,7 @@ ippReadIO(void *src, /* I - Data source */
+ }
+
+ bufptr = buffer;
++ bufend = buffer + n;
+
+ /*
+ * text-with-language and name-with-language are composite
+@@ -3454,7 +3456,7 @@ ippReadIO(void *src, /* I - Data source */
+
+ n = (bufptr[0] << 8) | bufptr[1];
+
+- if ((bufptr + 2 + n) >= (buffer + IPP_BUF_SIZE) || n >= (int)sizeof(string))
++ if ((bufptr + 2 + n + 2) > bufend || n >= (int)sizeof(string))
+ {
+ _cupsSetError(IPP_STATUS_ERROR_INTERNAL,
+ _("IPP language length overflows value."), 1);
+@@ -3481,7 +3483,7 @@ ippReadIO(void *src, /* I - Data source */
+ bufptr += 2 + n;
+ n = (bufptr[0] << 8) | bufptr[1];
+
+- if ((bufptr + 2 + n) >= (buffer + IPP_BUF_SIZE))
++ if ((bufptr + 2 + n) > bufend)
+ {
+ _cupsSetError(IPP_STATUS_ERROR_INTERNAL,
+ _("IPP string length overflows value."), 1);
diff --git a/gnu/packages/patches/linkchecker-tests-require-network.patch b/gnu/packages/patches/linkchecker-tests-require-network.patch
deleted file mode 100644
index f3e488cec2..0000000000
--- a/gnu/packages/patches/linkchecker-tests-require-network.patch
+++ /dev/null
@@ -1,182 +0,0 @@
-From f24c88a0732024028fffe0372039a847e91722ea Mon Sep 17 00:00:00 2001
-From: Christopher Baines <mail@cbaines.net>
-Date: Tue, 1 Jan 2019 22:36:29 +0000
-Subject: [PATCH] Mark more tests that require the network
-
-I believe all these tests require the network, at least they seem to
-fail if it's I run them without connecting my computer to the web.
-
-I'm looking at this as part of packaging linkchecker for GNU Guix,
-where the package is build and the tests are run in a isolated
-environment, intentionally without network access, to avoid issues
-with non-reproducible package builds.
----
- tests/checker/test_http.py | 2 ++
- tests/checker/test_http_misc.py | 2 ++
- tests/checker/test_http_redirect.py | 2 ++
- tests/checker/test_httpbin.py | 5 +++++
- tests/checker/test_misc.py | 4 ++++
- tests/checker/test_whitespace.py | 3 +++
- 6 files changed, 18 insertions(+)
-
-diff --git a/tests/checker/test_http.py b/tests/checker/test_http.py
-index e4c1e097..8a8af567 100644
---- a/tests/checker/test_http.py
-+++ b/tests/checker/test_http.py
-@@ -20,6 +20,7 @@
-
- import pytest
-
-+from tests import need_network
- from .httpserver import HttpServerTest, CookieRedirectHttpRequestHandler
-
- class TestHttp (HttpServerTest):
-@@ -29,6 +30,7 @@ def __init__(self, methodName='runTest'):
- super(TestHttp, self).__init__(methodName=methodName)
- self.handler = CookieRedirectHttpRequestHandler
-
-+ @need_network
- def test_html (self):
- confargs = dict(recursionlevel=1)
- self.file_test("http.html", confargs=confargs)
-diff --git a/tests/checker/test_http_misc.py b/tests/checker/test_http_misc.py
-index 9922d85f..c6b6afdb 100644
---- a/tests/checker/test_http_misc.py
-+++ b/tests/checker/test_http_misc.py
-@@ -20,11 +20,13 @@
- import os
- import sys
- from .httpserver import HttpServerTest
-+from tests import need_network
- from linkcheck.network import iputil
-
- class TestHttpMisc (HttpServerTest):
- """Test http:// misc link checking."""
-
-+ @need_network
- def test_html (self):
- self.swf_test()
- self.obfuscate_test()
-diff --git a/tests/checker/test_http_redirect.py b/tests/checker/test_http_redirect.py
-index f212d98e..2253a70d 100644
---- a/tests/checker/test_http_redirect.py
-+++ b/tests/checker/test_http_redirect.py
-@@ -17,6 +17,7 @@
- """
- Test http checking.
- """
-+from tests import need_network
- from .httpserver import HttpServerTest, CookieRedirectHttpRequestHandler
-
- class TestHttpRedirect (HttpServerTest):
-@@ -26,6 +27,7 @@ def __init__(self, methodName='runTest'):
- super(TestHttpRedirect, self).__init__(methodName=methodName)
- self.handler = CookieRedirectHttpRequestHandler
-
-+ @need_network
- def test_redirect (self):
- self.redirect1()
- self.redirect2()
-diff --git a/tests/checker/test_httpbin.py b/tests/checker/test_httpbin.py
-index 0319c2f6..4c8fa846 100644
---- a/tests/checker/test_httpbin.py
-+++ b/tests/checker/test_httpbin.py
-@@ -18,6 +18,7 @@
- Test http stuff with httpbin.org.
- """
- import re
-+from tests import need_network
- from . import LinkCheckTest
-
-
-@@ -30,6 +31,7 @@ def get_httpbin_url(path):
- class TestHttpbin(LinkCheckTest):
- """Test http:// link redirection checking."""
-
-+ @need_network
- def test_http_link(self):
- linkurl = u"http://www.example.com"
- nlinkurl = self.norm(linkurl)
-@@ -48,6 +50,7 @@ def test_http_link(self):
- ]
- self.direct(url, resultlines, recursionlevel=1)
-
-+ @need_network
- def test_basic_auth(self):
- user = u"testuser"
- password = u"testpassword"
-@@ -67,6 +70,7 @@ def test_basic_auth(self):
- ]
- self.direct(url, resultlines, confargs=confargs)
-
-+ @need_network
- def test_http_refresh_header(self):
- linkurl = u"http://www.example.com"
- nlinkurl = self.norm(linkurl)
-@@ -85,6 +89,7 @@ def test_http_refresh_header(self):
- ]
- self.direct(url, resultlines, recursionlevel=1)
-
-+ @need_network
- def test_http_content_location_header(self):
- linkurl = u"http://www.example.com"
- nlinkurl = self.norm(linkurl)
-diff --git a/tests/checker/test_misc.py b/tests/checker/test_misc.py
-index 2e4cfd07..f9591f9d 100644
---- a/tests/checker/test_misc.py
-+++ b/tests/checker/test_misc.py
-@@ -17,6 +17,7 @@
- """
- Test miscellaneous html tag parsing and URL types
- """
-+from tests import need_network
- from . import LinkCheckTest
-
-
-@@ -25,15 +26,18 @@ class TestMisc (LinkCheckTest):
- Test misc link types.
- """
-
-+ @need_network
- def test_misc (self):
- self.file_test("misc.html")
-
- def test_html5 (self):
- self.file_test("html5.html")
-
-+ @need_network
- def test_archive (self):
- self.file_test("archive.html")
-
-+ @need_network
- def test_itms_services(self):
- url = u"itms-services:?action=download-manifest&url=http://www.example.com/"
- resultlines = [
-diff --git a/tests/checker/test_whitespace.py b/tests/checker/test_whitespace.py
-index 609c108a..fc2727d6 100644
---- a/tests/checker/test_whitespace.py
-+++ b/tests/checker/test_whitespace.py
-@@ -17,6 +17,7 @@
- """
- Test whitespace handling.
- """
-+from tests import need_network
- from . import LinkCheckTest
-
-
-@@ -25,6 +26,7 @@ class TestWhitespace (LinkCheckTest):
- Test whitespace in URLs.
- """
-
-+ @need_network
- def test_leading_whitespace (self):
- # Leading whitespace
- url = u" http://www.example.org/"
-@@ -50,6 +52,7 @@ def test_leading_whitespace (self):
- ]
- self.direct(url, resultlines)
-
-+ @need_network
- def test_trailing_whitespace (self):
- # Trailing whitespace
- url = u"http://www.example.org/ "
diff --git a/gnu/packages/patches/tlf-support-hamlib-4.2+.patch b/gnu/packages/patches/tlf-support-hamlib-4.2+.patch
new file mode 100644
index 0000000000..3c5db10010
--- /dev/null
+++ b/gnu/packages/patches/tlf-support-hamlib-4.2+.patch
@@ -0,0 +1,66 @@
+From 295fa956f899af37acb6bda9c76ad77748eb9a4a Mon Sep 17 00:00:00 2001
+From: Ervin Hegedus <airween@gmail.com>
+Date: Sat, 5 Jun 2021 09:23:06 +0200
+Subject: [PATCH] Quick fix for changing of Hamlib's FILPATHLEN macro
+
+This patch was prepared for Guix by Jack Hill <jackhill@jackhill.us> by
+squashing together the changes from upstream #268
+<https://github.com/Tlf/tlf/pull/268>.
+
+It allows the released version of Tlf to build against the version 4.2 of
+hamlib in Guix.
+
+---
+ src/sendqrg.c | 6 +++---
+ src/sendqrg.h | 10 ++++++++++
+ 2 files changed, 13 insertions(+), 3 deletions(-)
+
+diff --git a/src/sendqrg.c b/src/sendqrg.c
+index ceeb356..5d4420e 100644
+--- a/src/sendqrg.c
++++ b/src/sendqrg.c
+@@ -87,7 +87,7 @@ int init_tlf_rig(void) {
+
+ rigportname[strlen(rigportname) - 1] = '\0'; // remove '\n'
+ strncpy(my_rig->state.rigport.pathname, rigportname,
+- FILPATHLEN - 1);
++ TLFFILPATHLEN - 1);
+
+ caps = my_rig->caps;
+
+@@ -104,9 +104,9 @@ int init_tlf_rig(void) {
+ if (dcd_type != RIG_DCD_NONE)
+ my_rig->state.dcdport.type.dcd = dcd_type;
+ if (ptt_file)
+- strncpy(my_rig->state.pttport.pathname, ptt_file, FILPATHLEN);
++ strncpy(my_rig->state.pttport.pathname, ptt_file, TLFFILPATHLEN);
+ if (dcd_file)
+- strncpy(my_rig->state.dcdport.pathname, dcd_file, FILPATHLEN);
++ strncpy(my_rig->state.dcdport.pathname, dcd_file, TLFFILPATHLEN);
+
+ my_rig->state.rigport.parm.serial.rate = serial_rate;
+
+diff --git a/src/sendqrg.h b/src/sendqrg.h
+index 8c53f2e..1ef85a6 100644
+--- a/src/sendqrg.h
++++ b/src/sendqrg.h
+@@ -23,6 +23,16 @@
+
+ #include <hamlib/rig.h>
+
++#ifdef HAMLIB_FILPATHLEN
++ #define TLFFILPATHLEN HAMLIB_FILPATHLEN
++#else
++ #ifdef FILPATHLEN
++ #define TLFFILPATHLEN FILPATHLEN
++ #else
++ #error "(HAMLIB_)FILPATHLEN macro not found"
++ #endif
++#endif
++
+ int init_tlf_rig(void);
+ void close_tlf_rig(RIG *my_rig);
+
+--
+2.32.0
+
diff --git a/gnu/packages/patches/widelands-system-wide_minizip.patch b/gnu/packages/patches/widelands-system-wide_minizip.patch
index 1fac0d5396..b59fed7531 100644
--- a/gnu/packages/patches/widelands-system-wide_minizip.patch
+++ b/gnu/packages/patches/widelands-system-wide_minizip.patch
@@ -2,41 +2,29 @@ Description: use the system-wide minizip instead of the embeeded one if found.
Forwarded-Upstream: It was provided by upstream: http://bazaar.launchpad.net/~widelands-dev/widelands/b19-debian/revision/8147
.
Thanks to Fòram na Gàidhlig for the patch.
-
-I just added this line to make its use easier:
- set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_HOME_DIRECTORY}/Modules)
=== modified file 'CMakeLists.txt'
---
- CMakeLists.txt | 3 +++
- Modules/FindMinizip.cmake | 37 +++++++++++++++++++++++++++++++++++++
- cmake/WlFunctions.cmake | 7 +++++++
- src/io/CMakeLists.txt | 2 +-
- src/third_party/CMakeLists.txt | 20 +++++++++++---------
- src/third_party/minizip/README.txt | 4 ++++
- 6 files changed, 63 insertions(+), 10 deletions(-)
+ CMakeLists.txt | 1 +
+ cmake/Modules/FindMinizip.cmake | 37 +++++++++++++++++++++++++++++++++++++
+ cmake/WlFunctions.cmake | 8 ++++++++
+ src/io/filesystem/CMakeLists.txt | 2 +-
+ src/io/filesystem/zip_filesystem.h | 6 ++++++
+ src/third_party/CMakeLists.txt | 20 +++++++++++---------
+ 6 files changed, 64 insertions(+), 10 deletions(-)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -43,6 +43,7 @@
- endif(POLICY CMP0074)
-
- include("${CMAKE_SOURCE_DIR}/cmake/WlFunctions.cmake")
-+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_HOME_DIRECTORY}/Modules)
-
- option(OPTION_USE_GLBINDING "Use glbinding instead of GLEW" OFF)
- option(OPTION_GLEW_STATIC "Use static GLEW Library" OFF)
-@@ -105,6 +106,8 @@
+@@ -142,6 +142,7 @@
+ find_package(SDL2_mixer REQUIRED)
find_package(SDL2_ttf REQUIRED)
find_package(ZLIB REQUIRED)
- find_package(ICU REQUIRED)
+find_package(Minizip)
-+
- if(OPTION_USE_GLBINDING)
- find_package(glbinding REQUIRED)
+ if(${CMAKE_VERSION} VERSION_LESS 3.9.0)
+ find_package(ICU_old REQUIRED)
else()
--- /dev/null
-+++ b/Modules/FindMinizip.cmake
++++ b/cmake/Modules/FindMinizip.cmake
@@ -0,0 +1,37 @@
+# - Try to find Minizip
+# Once done this will define
@@ -77,10 +65,10 @@ I just added this line to make its use easier:
+
--- a/cmake/WlFunctions.cmake
+++ b/cmake/WlFunctions.cmake
-@@ -81,6 +81,14 @@
+@@ -84,6 +84,14 @@
+
if(ARG_USES_ZLIB)
- wl_include_system_directories(${NAME} ${ZLIB_INCLUDE_DIRS})
- target_link_libraries(${NAME} ${ZLIB_LIBRARY})
+ target_link_libraries(${NAME} ZLIB::ZLIB)
+ if (MINIZIP_FOUND)
+ wl_include_system_directories(${NAME} ${MINIZIP_INCLUDE_DIR})
+ target_link_libraries(${NAME} ${MINIZIP_LIBRARY})
@@ -136,7 +124,7 @@ I just added this line to make its use easier:
)
--- a/src/io/filesystem/zip_filesystem.h
+++ b/src/io/filesystem/zip_filesystem.h
-@@ -28,8 +28,14 @@
+@@ -25,8 +25,14 @@
#include "io/filesystem/filesystem.h"
#include "io/streamread.h"
#include "io/streamwrite.h"