summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-04 17:35:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-04 17:46:28 +0200
commita3dea99107e20e3e50e9b766850254c87accde49 (patch)
treed43916a7632102384b996c43cbf50bea2a5f0177 /gnu/packages/patches
parent6beaa5a02a516c061c2ff86ce4beb43374015194 (diff)
downloadguix-patches-a3dea99107e20e3e50e9b766850254c87accde49.tar
guix-patches-a3dea99107e20e3e50e9b766850254c87accde49.tar.gz
gnu: python2-cython: Fix build on 32-bit platforms.
* gnu/packages/python.scm (python-cython, python2-cython)[source]: Add patch. * gnu/packages/patches/python-cython-fix-tests-32bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-cython-fix-tests-32bit.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-cython-fix-tests-32bit.patch b/gnu/packages/patches/python-cython-fix-tests-32bit.patch
new file mode 100644
index 0000000000..7ccc11dd4c
--- /dev/null
+++ b/gnu/packages/patches/python-cython-fix-tests-32bit.patch
@@ -0,0 +1,27 @@
+This fixes a test failure on 32-bit platforms.
+
+Upstream bug URL: https://github.com/cython/cython/issues/1548
+
+Patch copied from upstream source repository:
+
+https://github.com/cython/cython/commit/d92a718a26c9354fbf35f31a17de5c069865a447
+
+From d92a718a26c9354fbf35f31a17de5c069865a447 Mon Sep 17 00:00:00 2001
+From: Robert Bradshaw <robertwb@gmail.com>
+Date: Tue, 24 Jan 2017 16:57:00 -0800
+Subject: [PATCH] Normalize possible L suffix.
+
+---
+ tests/run/cpdef_enums.pyx | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/run/cpdef_enums.pyx b/tests/run/cpdef_enums.pyx
+index 167c762..c264ec5 100644
+--- a/tests/run/cpdef_enums.pyx
++++ b/tests/run/cpdef_enums.pyx
+@@ -93,4 +93,4 @@ def verify_resolution_GH1533():
+ 3
+ """
+ THREE = 100
+- return PyxEnum.THREE
++ return int(PyxEnum.THREE)