summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 14:59:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-05 09:46:52 -0500
commitdf93fc21a48047988b032ead90b0869491c834c8 (patch)
tree17b873fe20a0b1fc81ba3c8a8b7edb41645a7f10 /gnu/packages/patches
parentaa548d246977e40e8bd60acd9ee9f44468a83523 (diff)
downloadguix-patches-df93fc21a48047988b032ead90b0869491c834c8.tar
guix-patches-df93fc21a48047988b032ead90b0869491c834c8.tar.gz
gnu: rust: Bootstrap rust@1.29.2 by mrustc@0.9.
This reduced bootstrap reduces the complete Rust bootstrap chain build time by approximately 30% compared to the original (about 11 hours instead of 16 hours, on a fast machine). * gnu/packages/patches/rust-1.45-linker-locale.patch: Delete file. * gnu/packages/patches/rust-1.48-linker-locale.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register deleted files. * gnu/packages/rust.scm (%mrustc-source): New variable. (rust-1.29): New variable. It is bootstrapped from mrust 0.9, which is used in source form. (rust-1.30): New variable. (rust-1.31)[phases]{patch-command-exec-tests-phase}: Rewrite so that it doesn't need to be redefined later when the file is moved. {enable-docs}: New phase. (rust-1.32): Disable tests. [inputs]: Remove field. [phases]{override-jemalloc}: Reorder after the configure phase. (rust-1.33): Enable tests. [phases]{disable-codegen-tests}: New phase. (rust-1.34)[phases]{disable-codegen-tests}: Delete phase. (rust-1.35)[arguments]: Remove field. The disable-tidy-bins-check phase is now defined in rust-1.30. (rust-1.38)[phases]{patch-command-exec-tests-phase}: Remove. {patch-command-uid-gid-test}: Do not worry about the Tidy lint test, which is disabled. (rust-1.40)[phases]: Move #:validate-runpath? inside the use of 'substitute-keyword-arguments'. {neuter-tidy}: Delete. {patch-command-uid-gid-test}: Make the regexp more precise. Remove the TODO comment, which has been addressed. (rust-1.44)[inputs]: Replace python2 by python-wrapper. [phases]{use-python3}: New phase. (rust-1.45)[source]: Remove field. The linker locale fix is now made via ... [phases]{set-linker-locale-to-utf8}: ... this phase. (rust-1.46)[phases]{build, check}: Allow parallel execution. Add comments. {delete-install-logs}: Delete phase; it's now done in rust-1.30. (rust-1.47)[phases]{patch-cargo-checksums}: Do not reorder phase. The initial ordering of the phase has been fixed with in the rust-1.30 package. (rust-1.48)[source]: Remove field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rust-1.45-linker-locale.patch14
-rw-r--r--gnu/packages/patches/rust-1.48-linker-locale.patch14
2 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/rust-1.45-linker-locale.patch b/gnu/packages/patches/rust-1.45-linker-locale.patch
deleted file mode 100644
index 40220e8e77..0000000000
--- a/gnu/packages/patches/rust-1.45-linker-locale.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Patch will be included upstream in 1.47: https://github.com/rust-lang/rust/pull/74416
-diff --git a/src/librustc_codegen_ssa/back/linker.rs b/src/librustc_codegen_ssa/back/linker.rs
-index e64aafa599f..12575ac4358 100644
---- a/src/librustc_codegen_ssa/back/linker.rs
-+++ b/src/librustc_codegen_ssa/back/linker.rs
-@@ -28,7 +28,7 @@ use rustc_target::spec::{LinkOutputKind, LinkerFlavor, LldFlavor};
- pub fn disable_localization(linker: &mut Command) {
- // No harm in setting both env vars simultaneously.
- // Unix-style linkers.
-- linker.env("LC_ALL", "C");
-+ linker.env("LC_ALL", "en_US.UTF-8");
- // MSVC's `link.exe`.
- linker.env("VSLANG", "1033");
- }
diff --git a/gnu/packages/patches/rust-1.48-linker-locale.patch b/gnu/packages/patches/rust-1.48-linker-locale.patch
deleted file mode 100644
index d06dcbe682..0000000000
--- a/gnu/packages/patches/rust-1.48-linker-locale.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://github.com/rust-lang/rust/pull/74416
-diff --git a/compiler/rustc_codegen_ssa/src/back/linker.rs b/compiler/rustc_codegen_ssa/src/back/linker.rs
-index 3df956c465e..f45fee45be4 100644
---- a/compiler/rustc_codegen_ssa/src/back/linker.rs
-+++ b/compiler/rustc_codegen_ssa/src/back/linker.rs
-@@ -28,7 +28,7 @@
- pub fn disable_localization(linker: &mut Command) {
- // No harm in setting both env vars simultaneously.
- // Unix-style linkers.
-- linker.env("LC_ALL", "C");
-+ linker.env("LC_ALL", "en_US.UTF-8");
- // MSVC's `link.exe`.
- linker.env("VSLANG", "1033");
- }