summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-05 17:55:04 +0000
committerMarius Bakke <marius@gnu.org>2021-10-08 00:00:21 +0200
commit04c5d89482caa152881a453085e201e7b9b6576e (patch)
tree63edfca030c9900568c32a3b87e047a44df92891 /gnu/packages/patches
parentf86f7e24b39928247729020df0134e2e1c4cde62 (diff)
downloadguix-patches-04c5d89482caa152881a453085e201e7b9b6576e.tar
guix-patches-04c5d89482caa152881a453085e201e7b9b6576e.tar.gz
gnu: ceph: Fix breaking change in snappy.
* gnu/packages/storage.scm (ceph)[source]: Add patch. * gnu/packages/patches/ceph-fix-snappy-breaking-change.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ceph-fix-snappy-breaking-change.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch b/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
new file mode 100644
index 0000000000..7a10e2e4ae
--- /dev/null
+++ b/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
@@ -0,0 +1,13 @@
+Patch tracked upstream at https://tracker.ceph.com/issues/50934
+
+--- a/src/compressor/snappy/SnappyCompressor.h
++++ b/src/compressor/snappy/SnappyCompressor.h
+@@ -96,7 +96,7 @@ class SnappyCompressor : public Compressor {
+ if (qat_enabled)
+ return qat_accel.decompress(p, compressed_len, dst);
+ #endif
+- snappy::uint32 res_len = 0;
++ uint32_t res_len = 0;
+ BufferlistSource source_1(p, compressed_len);
+ if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
+ return -1;