summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-19 23:37:26 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:37 -0500
commitb78f0cbff4a5243d7bf2d6fc62c810d8f85b82a4 (patch)
tree0a55515bd64a8f4b31f6782c4dc05919e94f29f9 /gnu/packages/patches
parent8b1a6ee69d5290e619b3d9115d130c18347efc44 (diff)
downloadguix-patches-b78f0cbff4a5243d7bf2d6fc62c810d8f85b82a4.tar
guix-patches-b78f0cbff4a5243d7bf2d6fc62c810d8f85b82a4.tar.gz
gnu: gtk: Update to 4.4.1.
* gnu/packages/patches/gtk-introspection-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gtk.scm (gtk): Update to 4.4.1. [origin]: Apply new patch. [phases]{pre-check}: Set TZDIR. [native-inputs]: Add graphene, python-pygobject and tzdata.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gtk-introspection-test.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/gtk-introspection-test.patch b/gnu/packages/patches/gtk-introspection-test.patch
new file mode 100644
index 0000000000..570ea806a9
--- /dev/null
+++ b/gnu/packages/patches/gtk-introspection-test.patch
@@ -0,0 +1,22 @@
+# Extend rather than stomp environment variables.
+# Upstream status: https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/4268
+diff --git a/testsuite/introspection/meson.build b/testsuite/introspection/meson.build
+index 6202fb7446..b59191eb0f 100644
+--- a/testsuite/introspection/meson.build
++++ b/testsuite/introspection/meson.build
+@@ -1,9 +1,10 @@
++env = environment()
++env.prepend('GI_TYPELIB_PATH',
++ join_paths(project_build_root, 'gtk'),
++ gi_dep.get_pkgconfig_variable('typelibdir'))
++env.prepend('LD_PRELOAD', join_paths(project_build_root, 'gtk', 'libgtk-4.so'))
+
+ test('api',
+ find_program('api.py', dirs: meson.current_source_dir()),
+ suite: ['introspection'],
+- env: [
+- 'GI_TYPELIB_PATH=@0@/gtk:@1@'.format(project_build_root,
+- gi_dep.get_pkgconfig_variable('typelibdir')),
+- 'LD_PRELOAD=@0@/gtk/libgtk-4.so'.format(project_build_root),
+- ])
++ env: env)