summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-02 10:37:35 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-19 20:47:04 +0100
commit03cdd729c61ab475a97aeaa55cf79cf8b8e527ce (patch)
tree62090c35391f2ab76dd169db21d1e7bab27f2e98 /gnu/packages/patches
parent4ff6b34026719e7cb6a6c47f38e1d1fc9e92fac5 (diff)
downloadguix-patches-03cdd729c61ab475a97aeaa55cf79cf8b8e527ce.tar
guix-patches-03cdd729c61ab475a97aeaa55cf79cf8b8e527ce.tar.gz
gnu: audacity: Update to 3.1.3
* gnu/packages/patches/audacity-add-include.patch: Delete file. * gnu/packages/patches/audacity-build-with-system-portaudio.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/audio (audacity): Update to 3.1.3 [inputs]: Use wxwidgets-3.1. Add linux-libre-headers, libjpeg-turbo, sqlite, portaudio. [#:configure-flags]: Update to disable conan during build, prefer system libraries, and disable features that phone home. [#:phases]: Add fix-cmake-rpath to ensure correct DT_RUNPATHs. Adjust comment-out-revision-indent and use-upstream-headers. [native-search-paths]: Add AUDACITY_MODULES_PATH and AUDACITY_PATH.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/audacity-add-include.patch15
-rw-r--r--gnu/packages/patches/audacity-build-with-system-portaudio.patch62
2 files changed, 0 insertions, 77 deletions
diff --git a/gnu/packages/patches/audacity-add-include.patch b/gnu/packages/patches/audacity-add-include.patch
deleted file mode 100644
index a7f27918e7..0000000000
--- a/gnu/packages/patches/audacity-add-include.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Without <sys/time.h>, gettimeofday is undefined.
-
-diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
-index 0187e3962..e15d55f4c 100644
---- a/src/AudioIO.cpp
-+++ b/src/AudioIO.cpp
-@@ -479,6 +479,8 @@ time warp info and AudioIOListener and whether the playback is looped.
- #include "../lib-src/portmidi/porttime/porttime.h"
- #include "../lib-src/header-substitutes/allegro.h"
-
-+#include <sys/time.h>
-+
- #define MIDI_SLEEP 10 /* milliseconds */
- // how long do we think the thread that fills MIDI buffers,
- // if it is separate from the portaudio thread,
diff --git a/gnu/packages/patches/audacity-build-with-system-portaudio.patch b/gnu/packages/patches/audacity-build-with-system-portaudio.patch
deleted file mode 100644
index 05325a1493..0000000000
--- a/gnu/packages/patches/audacity-build-with-system-portaudio.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-Downloaded from here:
-https://sourceforge.net/p/audacity/mailman/message/36106562/
-
-Modified for use on later versions of audacity.
-
->From 5f9482a191359f2c477763a36d2c865c5f186602 Mon Sep 17 00:00:00 2001
-From: Antonio Ospite <ao2@ao2.it>
-Date: Tue, 7 Nov 2017 13:06:33 +0100
-Subject: [PATCH] Fix building against the system portaudio library
-
-Building against the system portaudio results in this error:
-
-./src/AudioIO.cpp:983: undefined reference to `PaUtil_GetTime'
-audacity-AudioIO.o: In function `audacityAudioCallback(void const*, void*,
-unsigned long, PaStreamCallbackTimeInfo const*, unsigned long, void*)':
-./src/AudioIO.cpp:4630: undefined reference to `PaUtil_GetTime'
-collect2: error: ld returned 1 exit status
-Makefile:2349: recipe for target 'audacity' failed
-make[3]: *** [audacity] Error 1
-
-This is because PaUtil_GetTime is declared as a C symbol in pa_util.h
-but is resolved as a C++ symbol at link time.
-
-Audacity fixes this in the local tree with this change:
-https://github.com/audacity/audacity/commit/38fd97b8e26060332ab3e9e000a8882326a70ba7
-
-However this is not general enough for the portaudio debian package.
-
-Since PaUtil_GetTime() is the only function causing problems, just copy
-over the code where it's used.
----
- src/AudioIO.cpp | 17 ++++++++++++++++-
- 1 file changed, 16 insertions(+), 1 deletion(-)
-
-diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
-index 48715869c..bb4bf472c 100644
---- a/src/AudioIO.cpp
-+++ b/src/AudioIO.cpp
-@@ -480,9 +480,22 @@ time warp info and AudioIOListener and whether the playback is looped.
- #define ROUND(x) (int) ((x)+0.5)
- //#include <string.h>
- // #include "../lib-src/portmidi/pm_common/portmidi.h"
-- #include "../lib-src/portaudio-v19/src/common/pa_util.h"
- #include "NoteTrack.h"
- #endif
-+PaTime PaUtil_GetTime( void )
-+{
-+#ifdef HAVE_MACH_ABSOLUTE_TIME
-+ return mach_absolute_time() * machSecondsConversionScaler_;
-+#elif defined(HAVE_CLOCK_GETTIME)
-+ struct timespec tp;
-+ clock_gettime(CLOCK_REALTIME, &tp);
-+ return (PaTime)(tp.tv_sec + tp.tv_nsec * 1e-9);
-+#else
-+ struct timeval tv;
-+ gettimeofday( &tv, NULL );
-+ return (PaTime) tv.tv_usec * 1e-6 + tv.tv_sec;
-+#endif
-+}
-
- #ifdef EXPERIMENTAL_AUTOMATED_INPUT_LEVEL_ADJUSTMENT
- #define LOWER_BOUND 0.0