summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-06 18:21:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 21:56:02 +0100
commit12818a0656817e95a80aace01089042c0b0e7e22 (patch)
tree5171530c3c9bdc703c13205bcfa2e173862981c6 /gnu/packages/patches
parent46c3a08b2ee8d5abae9f8fb42ff68dbf211dd261 (diff)
downloadguix-patches-12818a0656817e95a80aace01089042c0b0e7e22.tar
guix-patches-12818a0656817e95a80aace01089042c0b0e7e22.tar.gz
gnu: network-manager: Fix build with glibc 2.30.
* gnu/packages/patches/network-manager-gettid.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gnome.scm (network-manager)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/network-manager-gettid.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/network-manager-gettid.patch b/gnu/packages/patches/network-manager-gettid.patch
new file mode 100644
index 0000000000..d50b5f8102
--- /dev/null
+++ b/gnu/packages/patches/network-manager-gettid.patch
@@ -0,0 +1,20 @@
+glibc 2.30 added gettid() which conflicts with the implementation in
+NetworkManager. Remove for 1.17.1 and later versions.
+
+Adapted from upstream:
+https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/10276322bde8f015e48ac06f6a7509f514eb46f0
+
+--- a/src/systemd/sd-adapt/nm-sd-adapt.h
++++ b/src/systemd/sd-adapt/nm-sd-adapt.h
+@@ -181,9 +181,10 @@
+ #endif
+ }
+
+-static inline pid_t gettid(void) {
++static inline pid_t _nm_gettid(void) {
+ return (pid_t) syscall(SYS_gettid);
+ }
++#define gettid() _nm_gettid ()
+
+ /* we build with C11 and thus <uchar.h> provides char32_t,char16_t. */
+ #define HAVE_CHAR32_T 1