summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-09 21:03:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-10 10:15:25 +0200
commitf6c51f598ebb63c6933a8e157ea4592f8d078258 (patch)
treed25dab9ed767f4c9ff6270b6eaf1df305fd56491 /gnu/packages/patches
parentba469f1ad916ca12e7cec44af7edd209f1a146a0 (diff)
downloadguix-patches-f6c51f598ebb63c6933a8e157ea4592f8d078258.tar
guix-patches-f6c51f598ebb63c6933a8e157ea4592f8d078258.tar.gz
gnu: fribidi: Fix CVE-2019-18397.
* gnu/packages/fribidi.scm (fribidi): Replace with fribidi/fixed. (fribidi/fixed): New variable. * gnu/packages/patches/fribidi-CVE-2019-18397.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/fribidi-CVE-2019-18397.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/fribidi-CVE-2019-18397.patch b/gnu/packages/patches/fribidi-CVE-2019-18397.patch
new file mode 100644
index 0000000000..aff1a669b2
--- /dev/null
+++ b/gnu/packages/patches/fribidi-CVE-2019-18397.patch
@@ -0,0 +1,26 @@
+https://github.com/fribidi/fribidi/commit/034c6e9a1d296286305f4cfd1e0072b879f52568.patch
+
+From 034c6e9a1d296286305f4cfd1e0072b879f52568 Mon Sep 17 00:00:00 2001
+From: Dov Grobgeld <dov.grobgeld@gmail.com>
+Date: Thu, 24 Oct 2019 09:37:29 +0300
+Subject: [PATCH] Truncate isolate_level to FRIBIDI_BIDI_MAX_EXPLICIT_LEVEL
+
+---
+ lib/fribidi-bidi.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/lib/fribidi-bidi.c b/lib/fribidi-bidi.c
+index 6c84392..d384878 100644
+--- a/lib/fribidi-bidi.c
++++ b/lib/fribidi-bidi.c
+@@ -747,7 +747,9 @@ fribidi_get_par_embedding_levels_ex (
+ }
+
+ RL_LEVEL (pp) = level;
+- RL_ISOLATE_LEVEL (pp) = isolate_level++;
++ RL_ISOLATE_LEVEL (pp) = isolate_level;
++ if (isolate_level < FRIBIDI_BIDI_MAX_EXPLICIT_LEVEL-1)
++ isolate_level++;
+ base_level_per_iso_level[isolate_level] = new_level;
+
+ if (!FRIBIDI_IS_NEUTRAL (override))