summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-08 13:08:01 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 17:32:25 +0100
commita4c04bee7bc3faadf7ef6d98d83f57959f911fd1 (patch)
tree14b497747841f03f5d846b57502bbcb894542546 /gnu/packages/patches
parent63eb30c1915e774d1384c9c74feff28b2fbad744 (diff)
downloadguix-patches-a4c04bee7bc3faadf7ef6d98d83f57959f911fd1.tar
guix-patches-a4c04bee7bc3faadf7ef6d98d83f57959f911fd1.tar.gz
gnu: boost: Fix cross-compilation.
* gnu/packages/patches/boost-dumpversion.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/boost.scm (boost)[source]: Apply it, [native-inputs]: add python unless cross-compiling, [arguments]: pass cross-compilation mandatory flags and fill a user-config.jam file pointing to cross-compiler. Disable python support that is broken when cross-compiling. Disable provide-libboost_python when cross-compiling.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/boost-dumpversion.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/boost-dumpversion.patch b/gnu/packages/patches/boost-dumpversion.patch
new file mode 100644
index 0000000000..7df779cfe6
--- /dev/null
+++ b/gnu/packages/patches/boost-dumpversion.patch
@@ -0,0 +1,24 @@
+This issue is described here: https://github.com/openwrt/packages/pull/8685
+and has not been solved as of 1.70.0 release.
+
+--- a/tools/build/src/tools/common.jam
++++ b/tools/build/src/tools/common.jam
+@@ -973,18 +973,6 @@
+ }
+ }
+
+- # From GCC 5, versioning changes and minor becomes patch
+- if $(tag) = gcc && [ numbers.less 4 $(version[1]) ]
+- {
+- version = $(version[1]) ;
+- }
+-
+- # Ditto, from Clang 4
+- if ( $(tag) = clang || $(tag) = clangw ) && [ numbers.less 3 $(version[1]) ]
+- {
+- version = $(version[1]) ;
+- }
+-
+ # On intel, version is not added, because it does not matter and it is the
+ # version of vc used as backend that matters. Ideally, we should encode the
+ # backend version but that would break compatibility with V1.