summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-22 23:36:09 +0100
committerMarius Bakke <marius@gnu.org>2020-11-22 23:36:09 +0100
commita485a98ca8296d760251e9d870583117ac50979e (patch)
tree792df6983c0e52403a6c3b82c804f295369a9b1d /gnu/packages/patches
parent84d1b500f078b619daba35864c703890bd91e5c2 (diff)
parent1ca0c348674dd4dec2ccb5a2d79b4cfd03a631ef (diff)
downloadguix-patches-a485a98ca8296d760251e9d870583117ac50979e.tar
guix-patches-a485a98ca8296d760251e9d870583117ac50979e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch11
-rw-r--r--gnu/packages/patches/xpra-4.0.4-norequests.patch39
2 files changed, 11 insertions, 39 deletions
diff --git a/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch b/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
new file mode 100644
index 0000000000..cb3313197c
--- /dev/null
+++ b/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
@@ -0,0 +1,11 @@
+--- a/gajim/common/configpaths.py 2020-11-19 12:12:02.004414323 +0100
++++ a/gajim/common/configpaths.py 2020-11-19 15:34:52.211476895 +0100
+@@ -47,7 +47,7 @@
+ return [Path(_paths['PLUGINS_BASE']),
+ Path('/app/plugins')]
+ return [Path(_paths['PLUGINS_BASE']),
+- Path(_paths['PLUGINS_USER'])]
++ Path(_paths['PLUGINS_USER'])] + ([Path(os.getenv('GAJIM_PLUGIN_PATH'))] if os.getenv('GAJIM_PLUGIN_PATH') and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() else [])
+
+
+ def get_paths(type_: PathType) -> Generator[str, None, None]:
diff --git a/gnu/packages/patches/xpra-4.0.4-norequests.patch b/gnu/packages/patches/xpra-4.0.4-norequests.patch
deleted file mode 100644
index e545be7f1d..0000000000
--- a/gnu/packages/patches/xpra-4.0.4-norequests.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Remove python-requests dependency, r27626 upstream.
-
---- a/xpra/net/websockets/common.py (revision 27625)
-+++ b/xpra/net/websockets/common.py (revision 27626)
-@@ -7,7 +7,6 @@
- import uuid
- from hashlib import sha1
- from base64 import b64encode
--from requests.structures import CaseInsensitiveDict
-
- from xpra.os_util import strtobytes, bytestostr, monotonic_time
- from xpra.log import Logger
-@@ -77,7 +76,7 @@
- for line in lines:
- parts = line.split(b": ", 1)
- if len(parts)==2:
-- headers[parts[0]] = parts[1]
-+ headers[parts[0].lower()] = parts[1]
- return headers
-
- def verify_response_headers(headers, key):
-@@ -84,14 +83,13 @@
- log("verify_response_headers(%s)", headers)
- if not headers:
- raise Exception("no http headers found in response")
-- headers = CaseInsensitiveDict(headers)
-- upgrade = headers.get(b"Upgrade", b"")
-+ upgrade = headers.get(b"upgrade", b"")
- if upgrade!=b"websocket":
- raise Exception("invalid http upgrade: '%s'" % upgrade)
-- protocol = headers.get(b"Sec-WebSocket-Protocol", b"")
-+ protocol = headers.get(b"sec-websocket-protocol", b"")
- if protocol!=b"binary":
- raise Exception("invalid websocket protocol: '%s'" % protocol)
-- accept_key = headers.get(b"Sec-WebSocket-Accept", b"")
-+ accept_key = headers.get(b"sec-websocket-accept", b"")
- if not accept_key:
- raise Exception("websocket accept key is missing")
- expected_key = make_websocket_accept_hash(key)