summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-31 11:13:49 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-31 15:23:05 +0200
commit58dce7bfb59d4f89b035c9bf181e73f4b667b57c (patch)
tree9e4c223cb252eb3195bffacbdcaf33fabb537379 /gnu/packages/patches
parent6ce8fe4cd01be01c817627a75650475cbf572ff9 (diff)
downloadguix-patches-58dce7bfb59d4f89b035c9bf181e73f4b667b57c.tar
guix-patches-58dce7bfb59d4f89b035c9bf181e73f4b667b57c.tar.gz
gnu: libgit2: Update to 0.26.0.
* gnu/packages/version-control.scm (libgit2): Update to 0.26.0. Remove "libgit2-use-after-free.patch". * gnu/packages/patches/libgit2-use-after-free.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libgit2-use-after-free.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/patches/libgit2-use-after-free.patch b/gnu/packages/patches/libgit2-use-after-free.patch
deleted file mode 100644
index 580af8781a..0000000000
--- a/gnu/packages/patches/libgit2-use-after-free.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This patch is taken from <https://github.com/libgit2/libgit2/pull/4122>;
-we need it to fix the use-after-free error in 'git_commit_extract_signature'
-reported at <https://github.com/libgit2/libgit2/issues/4118>.
-
-From ade0d9c658fdfc68d8046935f6908f033fe7a529 Mon Sep 17 00:00:00 2001
-From: Patrick Steinhardt <ps@pks.im>
-Date: Mon, 13 Feb 2017 13:46:17 +0100
-Subject: [PATCH 3/3] commit: avoid possible use-after-free
-
-diff --git a/src/commit.c b/src/commit.c
-index 89a4db1..05b70a9 100644
---- a/src/commit.c
-+++ b/src/commit.c
-@@ -766,8 +766,9 @@ int git_commit_extract_signature(git_buf *signature, git_buf *signed_data, git_r
- if (git_buf_oom(signature))
- goto oom;
-
-+ error = git_buf_puts(signed_data, eol+1);
- git_odb_object_free(obj);
-- return git_buf_puts(signed_data, eol+1);
-+ return error;
- }
-
- giterr_set(GITERR_OBJECT, "this commit is not signed");