summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-15 10:30:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-15 10:31:20 +0300
commit3837108e403d385cd0b616fb601b9942c8bb213f (patch)
tree3a8d0af86f7826e0006d9283bc0b5d3af59068e1 /gnu/packages/patches
parent2d430f29231d0d817459d86e0fe15089372e9547 (diff)
downloadguix-patches-3837108e403d385cd0b616fb601b9942c8bb213f.tar
guix-patches-3837108e403d385cd0b616fb601b9942c8bb213f.tar.gz
gnu: bcftools: Fix building on aarch64.
* gnu/packages/patches/bcftools-regidx-unsigned-char.patch: New file. * gnu/packages/bioinformatics.scm (bcftools)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bcftools-regidx-unsigned-char.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/bcftools-regidx-unsigned-char.patch b/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
new file mode 100644
index 0000000000..af5bc160f5
--- /dev/null
+++ b/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
@@ -0,0 +1,16 @@
+Description: Fix test-regidx argument parsing on archs with unsigned char
+ On architectures where char is unsigned "c >= 0" was always true.
+Author: Adrian Bunk <bunk@debian.org>
+Bug-Debian: https://bugs.debian.org/865060
+
+--- a/test/test-regidx.c
++++ b/test/test-regidx.c
+@@ -336,7 +336,7 @@
+ {"seed",1,0,'s'},
+ {0,0,0,0}
+ };
+- char c;
++ int c;
+ int seed = (int)time(NULL);
+ while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0)
+ {