summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2021-12-01 18:05:26 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-01 18:05:26 +0100
commitc7c4f8088195a8e6650904de4e16d71b98776a76 (patch)
treea41946cfc0ef197f0f440c925a80ce82d6be66b1 /gnu/packages/patches
parent508200d66acb5f6d38a53e787f78d7ae388b8083 (diff)
downloadguix-patches-c7c4f8088195a8e6650904de4e16d71b98776a76.tar
guix-patches-c7c4f8088195a8e6650904de4e16d71b98776a76.tar.gz
gnu: Update Trezor support.
* gnu/packages/patches/python-trezor-agent-fix-argv0.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Apply previous removal. * gnu/packages/finance.scm (python-trezor-agent): Update to 0.14.4. [source]: Remove now useless patch. (python-mnemonic): Update to 0.20. (python-trezor): Update to 0.12.4 (trezor-agent): Update to 0.11.0-1. [source]: Add file-name field. [arguments]: Remove trailing #T in phases. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-trezor-agent-fix-argv0.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/patches/python-trezor-agent-fix-argv0.patch b/gnu/packages/patches/python-trezor-agent-fix-argv0.patch
deleted file mode 100644
index 9462067cd5..0000000000
--- a/gnu/packages/patches/python-trezor-agent-fix-argv0.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/libagent/gpg/__init__.py b/libagent/gpg/__init__.py
-index 3711bc8..67085de 100644
---- a/libagent/gpg/__init__.py
-+++ b/libagent/gpg/__init__.py
-@@ -122,15 +122,19 @@ def run_init(device_type, args):
- verify_gpg_version()
-
- # Prepare new GPG home directory for hardware-based identity
-- device_name = os.path.basename(sys.argv[0]).rsplit('-', 1)[0]
-- log.info('device name: %s', device_name)
-+ exe_name = os.path.basename(sys.argv[0])
-+ # drop the Guix wrapper's dot prefix from the name
-+ if exe_name[0] == '.' and exe_name.endswith('-real'):
-+ exe_name = exe_name[1:-5:]
-+ device_name = exe_name.rsplit('-', 1)[0]
-+ log.info('exe name: %s, device name: %s', exe_name, device_name)
- homedir = args.homedir
- if not homedir:
- homedir = os.path.expanduser('~/.gnupg/{}'.format(device_name))
-
- log.info('GPG home directory: %s', homedir)
-
-- if os.path.exists(homedir):
-+ if os.path.exists(homedir) and not args.subkey:
- log.error('GPG home directory %s exists, '
- 'remove it manually if required', homedir)
- sys.exit(1)