summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 14:02:44 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:59 +0200
commit2a0fcc31f723e20fd81eb3c6263c1bdad56f797f (patch)
tree31c6ced16ad87a66d93b16c2ed6f51bde8566112 /gnu/packages/patches
parentb3c1c37d743f55c716727a3efe9067654b9687f5 (diff)
downloadguix-patches-2a0fcc31f723e20fd81eb3c6263c1bdad56f797f.tar
guix-patches-2a0fcc31f723e20fd81eb3c6263c1bdad56f797f.tar.gz
gnu: Add aws-c-mqtt.
* gnu/packages/c.scm (aws-c-mqtt): New variable. * gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch b/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch
new file mode 100644
index 0000000000..987024b57c
--- /dev/null
+++ b/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()