summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-07 20:49:14 -0400
committerLeo Famulari <leo@famulari.name>2018-10-07 20:49:14 -0400
commite8bd1946ec1df9f52f87292172af5b4e4a4e0023 (patch)
treee3209b814be53b0c21f29438a491c2aedcc2d1c5 /gnu/packages/patches
parentcf6db76d2af2f287f12928df160447ab4165b3e5 (diff)
parenta18accba468beecf0200383f56d02894caf6f41a (diff)
downloadguix-patches-e8bd1946ec1df9f52f87292172af5b4e4a4e0023.tar
guix-patches-e8bd1946ec1df9f52f87292172af5b4e4a4e0023.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bastet-change-source-of-unordered_set.patch40
-rw-r--r--gnu/packages/patches/borg-respect-storage-quota.patch32
-rw-r--r--gnu/packages/patches/gnucash-disable-failing-tests.patch39
-rw-r--r--gnu/packages/patches/gnucash-price-quotes-perl.patch5
-rw-r--r--gnu/packages/patches/mes-nyacc-0.86.0.patch197
5 files changed, 114 insertions, 199 deletions
diff --git a/gnu/packages/patches/bastet-change-source-of-unordered_set.patch b/gnu/packages/patches/bastet-change-source-of-unordered_set.patch
new file mode 100644
index 0000000000..ef3970a3e2
--- /dev/null
+++ b/gnu/packages/patches/bastet-change-source-of-unordered_set.patch
@@ -0,0 +1,40 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Wed, 3 Oct 2018 23:30:42 +0200
+Subject: [PATCH] bastet: Change source of unordered_set.
+
+This allows building bastet 0.43.2 with boost >=1.66.
+It was backported verbatim from the upstream master branch.
+
+From 0e03f8d4d6bc6949cf1c447e632ce0d1b98c4be1 Mon Sep 17 00:00:00 2001
+From: Federico Poloni <fpoloni@di.unipi.it>
+Date: Wed, 4 Oct 2017 19:35:01 +0200
+Subject: [PATCH] Changed source of unordered_set (should hopefully fix #6
+ without reopening #1)
+
+---
+ BastetBlockChooser.hpp | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/BastetBlockChooser.hpp b/BastetBlockChooser.hpp
+index 992e556..7ee3b7c 100644
+--- a/BastetBlockChooser.hpp
++++ b/BastetBlockChooser.hpp
+@@ -23,8 +23,7 @@
+
+ #include "Well.hpp"
+
+-#include <boost/tr1/tr1/unordered_set>
+-#include <set>
++#include <boost/unordered_set.hpp>
+ #include <boost/functional/hash.hpp>
+
+ namespace Bastet{
+@@ -75,7 +74,7 @@ namespace Bastet{
+ public:
+ Searcher(BlockType b, const Well *well, Vertex v, WellVisitor *visitor);
+ private:
+- std::tr1::unordered_set<Vertex> _visited;
++ boost::unordered_set<Vertex> _visited;
+ //std::set<Vertex> _visited; ^^ the above is more efficient, we need to do many inserts
+ BlockType _block;
+ const Well *_well;
diff --git a/gnu/packages/patches/borg-respect-storage-quota.patch b/gnu/packages/patches/borg-respect-storage-quota.patch
new file mode 100644
index 0000000000..d23d1ffc01
--- /dev/null
+++ b/gnu/packages/patches/borg-respect-storage-quota.patch
@@ -0,0 +1,32 @@
+Make sure the client respects the storage quota set by the server:
+
+https://github.com/borgbackup/borg/issues/4093
+
+Patch copied from upstream source repository:
+
+https://github.com/borgbackup/borg/commit/975cc33206e0e3644626fb7204c34d2157715b61
+
+From 975cc33206e0e3644626fb7204c34d2157715b61 Mon Sep 17 00:00:00 2001
+From: Manu <manu@snapdragon.cc>
+Date: Wed, 3 Oct 2018 23:47:36 +0800
+Subject: [PATCH] Add storage_quota for forced_result if set by serve command.
+
+---
+ src/borg/archiver.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/borg/archiver.py b/src/borg/archiver.py
+index 916725e7..279194c1 100644
+--- a/src/borg/archiver.py
++++ b/src/borg/archiver.py
+@@ -4276,6 +4276,7 @@ def get_args(self, argv, cmd):
+ result.restrict_to_paths = forced_result.restrict_to_paths
+ result.restrict_to_repositories = forced_result.restrict_to_repositories
+ result.append_only = forced_result.append_only
++ result.storage_quota = forced_result.storage_quota
+ return result
+
+ def parse_args(self, args=None):
+--
+2.19.1
+
diff --git a/gnu/packages/patches/gnucash-disable-failing-tests.patch b/gnu/packages/patches/gnucash-disable-failing-tests.patch
new file mode 100644
index 0000000000..e0fdd86b5d
--- /dev/null
+++ b/gnu/packages/patches/gnucash-disable-failing-tests.patch
@@ -0,0 +1,39 @@
+test-stress-options.scm does not exist, and test-qof passes when run in the
+build directory after the gnucash build.
+
+diff -ur gnucash-3.3.old/gnucash/report/standard-reports/test/CMakeLists.txt gnucash-3.3/gnucash/report/standard-reports/test/CMakeLists.txt
+--- gnucash-3.3.old/gnucash/report/standard-reports/test/CMakeLists.txt 2018-10-04 09:29:00.916641417 -0400
++++ gnucash-3.3/gnucash/report/standard-reports/test/CMakeLists.txt 2018-10-04 09:30:52.962504860 -0400
+@@ -13,10 +13,6 @@
+ test-income-gst.scm
+ )
+
+-set(scm_test_with_textual_ports_SOURCES
+- test-stress-options.scm
+-)
+-
+ set(GUILE_DEPENDS
+ scm-gnc-module
+ scm-app-utils
+@@ -31,9 +27,6 @@
+
+ if (HAVE_SRFI64)
+ gnc_add_scheme_tests("${scm_test_with_srfi64_SOURCES}")
+- if (HAVE_TEXT_PORTS)
+- gnc_add_scheme_tests("${scm_test_with_textual_ports_SOURCES}")
+- endif (HAVE_TEXT_PORTS)
+ endif (HAVE_SRFI64)
+
+ gnc_add_scheme_tests("${scm_test_standard_reports_SOURCES}")
+diff -ur gnucash-3.3.old/libgnucash/engine/test/CMakeLists.txt gnucash-3.3/libgnucash/engine/test/CMakeLists.txt
+--- gnucash-3.3.old/libgnucash/engine/test/CMakeLists.txt 2018-10-04 09:29:00.876640751 -0400
++++ gnucash-3.3/libgnucash/engine/test/CMakeLists.txt 2018-10-05 10:46:22.542962546 -0400
+@@ -54,8 +54,6 @@
+ # This test does not run on Win32
+ if (NOT WIN32)
+ set(SOURCES ${test_qof_SOURCES} ${CMAKE_SOURCE_DIR}/common/test-core/unittest-support.c)
+- add_engine_test(test-qof "${SOURCES}")
+- target_compile_definitions(test-qof PRIVATE TESTPROG=test_qof)
+
+ set(SOURCES ${test_engine_SOURCES} ${CMAKE_SOURCE_DIR}/common/test-core/unittest-support.c)
+ add_engine_test(test-engine "${SOURCES}")
diff --git a/gnu/packages/patches/gnucash-price-quotes-perl.patch b/gnu/packages/patches/gnucash-price-quotes-perl.patch
index 982763f0ec..3101ddb007 100644
--- a/gnu/packages/patches/gnucash-price-quotes-perl.patch
+++ b/gnu/packages/patches/gnucash-price-quotes-perl.patch
@@ -1,8 +1,9 @@
After wrapping gnc-fq-check and gnc-fq-helper we can no longer execute them
with perl, so execute them directly instead.
---- gnucash-2.6.6/src/scm/price-quotes.scm.orig 2014-04-27 17:42:28.000000000 -0500
-+++ gnucash-2.6.6/src/scm/price-quotes.scm 2015-07-09 16:12:11.196218472 -0500
+diff -ur gnucash-3.2.old/libgnucash/scm/price-quotes.scm gnucash-3.2/libgnucash/scm/price-quotes.scm
+--- gnucash-3.2.old/libgnucash/scm/price-quotes.scm 2018-09-15 00:48:33.718389646 -0400
++++ gnucash-3.2/libgnucash/scm/price-quotes.scm 2018-09-15 13:51:49.249862724 -0400
@@ -74,7 +74,7 @@
(define (start-program)
(if (not (string-null? gnc:*finance-quote-check*))
diff --git a/gnu/packages/patches/mes-nyacc-0.86.0.patch b/gnu/packages/patches/mes-nyacc-0.86.0.patch
deleted file mode 100644
index 58dfc5a46b..0000000000
--- a/gnu/packages/patches/mes-nyacc-0.86.0.patch
+++ /dev/null
@@ -1,197 +0,0 @@
-From 9e610736bf779f3295c1192e748cd19cbbe3be28 Mon Sep 17 00:00:00 2001
-From: Jan Nieuwenhuizen <janneke@gnu.org>
-Date: Wed, 5 Sep 2018 20:28:06 +0200
-Subject: [PATCH 1/2] mes: Support Nyacc 0.85.3: Add char-set-copy.
-
-* mes/module/srfi/srfi-14.mes (char-set-copy): New function>
----
- mes/module/srfi/srfi-14.mes | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/mes/module/srfi/srfi-14.mes b/mes/module/srfi/srfi-14.mes
-index 0be39b1e..a16d16ce 100644
---- a/mes/module/srfi/srfi-14.mes
-+++ b/mes/module/srfi/srfi-14.mes
-@@ -52,3 +52,6 @@
-
- (define (char-whitespace? c)
- (char-set-contains? char-set:whitespace c))
-+
-+(define (char-set-copy cs)
-+ (map identity cs))
---
-2.18.0
-
-From b952bdf44f11edbfc277600dc35236aae1769b54 Mon Sep 17 00:00:00 2001
-From: Jan Nieuwenhuizen <janneke@gnu.org>
-Date: Wed, 5 Sep 2018 22:14:34 +0200
-Subject: [PATCH 2/2] mes: Support Nyacc 0.85.3: Integrate progress.
-
-* mes/module/nyacc/lang/sx-util.mes: New file.
-* mes/module/nyacc/version.mes: New file.
-* mes/module/nyacc/lang/c99/cpp.mes (nyacc): Include them.
-* mes/module/nyacc/lang/c99/parser.mes (nyacc): Include them.
-* module/mescc/preprocess.scm (need-progress): New function.
-(progress): New function.
-(insert-progress-monitors): Use them to Integrate progress.
----
- mes/module/mescc/preprocess.mes | 1 +
- mes/module/nyacc/lang/c99/cpp.mes | 1 +
- mes/module/nyacc/lang/c99/parser.mes | 1 +
- mes/module/nyacc/lang/sx-util.mes | 27 +++++++++++++++++++++
- mes/module/nyacc/version.mes | 26 +++++++++++++++++++++
- module/mescc/preprocess.scm | 35 ++++++++++++++++++++++++++++
- 6 files changed, 91 insertions(+)
- create mode 100644 mes/module/nyacc/lang/sx-util.mes
- create mode 100644 mes/module/nyacc/version.mes
-
-diff --git a/mes/module/mescc/preprocess.mes b/mes/module/mescc/preprocess.mes
-index c7c5fcaa..022a372c 100644
---- a/mes/module/mescc/preprocess.mes
-+++ b/mes/module/mescc/preprocess.mes
-@@ -24,4 +24,5 @@
- (mes-use-module (srfi srfi-13))
- (mes-use-module (srfi srfi-26))
- (mes-use-module (nyacc lang c99 parser))
-+(mes-use-module (nyacc version))
- (include-from-path "mescc/preprocess.scm")
-diff --git a/mes/module/nyacc/lang/c99/cpp.mes b/mes/module/nyacc/lang/c99/cpp.mes
-index fad1dc55..b25c4a93 100644
---- a/mes/module/nyacc/lang/c99/cpp.mes
-+++ b/mes/module/nyacc/lang/c99/cpp.mes
-@@ -28,5 +28,6 @@
-
- (mes-use-module (nyacc parse))
- (mes-use-module (nyacc lex))
-+(mes-use-module (nyacc lang sx-util))
- (mes-use-module (nyacc lang util))
- (include-from-path "nyacc/lang/c99/cpp.scm")
-diff --git a/mes/module/nyacc/lang/c99/parser.mes b/mes/module/nyacc/lang/c99/parser.mes
-index c51552d6..1a9aaf73 100644
---- a/mes/module/nyacc/lang/c99/parser.mes
-+++ b/mes/module/nyacc/lang/c99/parser.mes
-@@ -32,6 +32,7 @@
-
- (mes-use-module (nyacc lex))
- (mes-use-module (nyacc parse))
-+(mes-use-module (nyacc lang sx-util))
- (mes-use-module (nyacc lang util))
- (mes-use-module (nyacc lang c99 cpp))
-
-diff --git a/mes/module/nyacc/lang/sx-util.mes b/mes/module/nyacc/lang/sx-util.mes
-new file mode 100644
-index 00000000..41ac5b4a
---- /dev/null
-+++ b/mes/module/nyacc/lang/sx-util.mes
-@@ -0,0 +1,27 @@
-+;;; -*-scheme-*-
-+
-+;;; GNU Mes --- Maxwell Equations of Software
-+;;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-+;;;
-+;;; This file is part of GNU Mes.
-+;;;
-+;;; GNU Mes is free software; you can redistribute it and/or modify it
-+;;; under the terms of the GNU General Public License as published by
-+;;; the Free Software Foundation; either version 3 of the License, or (at
-+;;; your option) any later version.
-+;;;
-+;;; GNU Mes is distributed in the hope that it will be useful, but
-+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+;;; GNU General Public License for more details.
-+;;;
-+;;; You should have received a copy of the GNU General Public License
-+;;; along with GNU Mes. If not, see <http://www.gnu.org/licenses/>.
-+
-+;;; Commentary:
-+
-+;;; Code:
-+
-+(mes-use-module (srfi srfi-1))
-+(mes-use-module (srfi srfi-16))
-+(include-from-path "nyacc/lang/sx-util.scm")
-diff --git a/mes/module/nyacc/version.mes b/mes/module/nyacc/version.mes
-new file mode 100644
-index 00000000..b9db628e
---- /dev/null
-+++ b/mes/module/nyacc/version.mes
-@@ -0,0 +1,26 @@
-+;;; -*-scheme-*-
-+
-+;;; GNU Mes --- Maxwell Equations of Software
-+;;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-+;;;
-+;;; This file is part of GNU Mes.
-+;;;
-+;;; GNU Mes is free software; you can redistribute it and/or modify it
-+;;; under the terms of the GNU General Public License as published by
-+;;; the Free Software Foundation; either version 3 of the License, or (at
-+;;; your option) any later version.
-+;;;
-+;;; GNU Mes is distributed in the hope that it will be useful, but
-+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+;;; GNU General Public License for more details.
-+;;;
-+;;; You should have received a copy of the GNU General Public License
-+;;; along with GNU Mes. If not, see <http://www.gnu.org/licenses/>.
-+
-+;;; Commentary:
-+
-+;;; Code:
-+
-+(include-from-path "nyacc/version.scm")
-+(display "nyacc version\n")
-diff --git a/module/mescc/preprocess.scm b/module/mescc/preprocess.scm
-index 9e341cba..c2efb32c 100644
---- a/module/mescc/preprocess.scm
-+++ b/module/mescc/preprocess.scm
-@@ -26,9 +26,44 @@
- #:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26)
- #:use-module (nyacc lang c99 parser)
-+ #:use-module (nyacc lang c99 parser)
-+ #:use-module (nyacc version)
- #:use-module (mes guile)
- #:export (c99-input->ast))
-
-+(format (current-error-port) "*nyacc-version*=~a\n" *nyacc-version*)
-+;; list of which rules you want progress reported
-+(define need-progress
-+ (assoc-ref
-+ '(("0.85.3" (1 2 3))
-+ ("0.86.0" (1 2 3)))
-+ *nyacc-version*))
-+
-+(define (progress o)
-+ (when (and o (getenv "NYACC_DEBUG"))
-+ (display " :" (current-error-port))
-+ (display o (current-error-port))
-+ (display "\n" (current-error-port))))
-+
-+(define (insert-progress-monitors act-v len-v)
-+ (let ((n (vector-length act-v)))
-+ (let loop ((ix 0))
-+ (when (< ix n)
-+ (if (memq ix need-progress)
-+ (vector-set
-+ act-v ix
-+ (lambda args
-+ (progress (list-ref args (1- (vector-ref len-v ix))))
-+ (apply (vector-ref act-v ix) args))))
-+ (loop (1+ ix))))))
-+
-+(cond-expand
-+ (guile
-+ (insert-progress-monitors (@@ (nyacc lang c99 parser) c99-act-v)
-+ (@@ (nyacc lang c99 parser) c99-len-v)))
-+ (mes
-+ (insert-progress-monitors c99-act-v c99-len-v)))
-+
- (define (logf port string . rest)
- (apply format (cons* port string rest))
- (force-output port)
---
-2.18.0
-