summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJacob Hrbek <kreyren@rixotstudio.cz>2021-11-18 20:37:52 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-18 23:35:37 +0100
commit92d6f17dfd449208a657a1a54e3a287ae22d1da8 (patch)
tree74447b808e29c329fb86bcca97e606cf4b6e934f /gnu/packages/patches
parenta8eea7a51e243587b7e0b12c2a769ace6f05351d (diff)
downloadguix-patches-92d6f17dfd449208a657a1a54e3a287ae22d1da8.tar
guix-patches-92d6f17dfd449208a657a1a54e3a287ae22d1da8.tar.gz
gnu: Add shell2batch.
* gnu/packages/crates-io.scm (shell2batch): New variable. * gnu/packages/patches/rust-shell2batch-lint-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rust-shell2batch-lint-fix.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-shell2batch-lint-fix.patch b/gnu/packages/patches/rust-shell2batch-lint-fix.patch
new file mode 100644
index 0000000000..7c160b6cca
--- /dev/null
+++ b/gnu/packages/patches/rust-shell2batch-lint-fix.patch
@@ -0,0 +1,25 @@
+Resolves the following error that was most likely introduced in new version of
+rust as this package is from 2019:
+
+error: unnecessary parentheses around type
+ --> src/converter.rs:108:61
+ |
+108 | fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
+ | ^^^^^^^^ help: remove these parentheses
+
+Reported upstream at https://github.com/sagiegurari/shell2batch/issues/17.
+
+diff --git a/src/converter.rs b/src/converter.rs
+index fc87d68..af309d2 100644
+--- a/src/converter.rs
++++ b/src/converter.rs
+@@ -105,7 +105,7 @@ fn replace_vars(arguments: &str) -> String {
+ updated_arguments
+ }
+
+-fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
++fn add_arguments(arguments: &str, additional_arguments: Vec<String>, pre: bool) -> String {
+ let mut windows_arguments = if pre {
+ "".to_string()
+ } else {
+