summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-25 23:18:04 +0100
committerMarius Bakke <marius@gnu.org>2021-12-26 00:58:27 +0100
commit52d945d382041488f8e71c0fb8af874ede148512 (patch)
tree620971cf2e7fb44e4084ecae4826f7160a59d7d8 /gnu/packages/patches
parent9d9c7d2202980a70e2156460f30c85b4efc0f99a (diff)
downloadguix-patches-52d945d382041488f8e71c0fb8af874ede148512.tar
guix-patches-52d945d382041488f8e71c0fb8af874ede148512.tar.gz
gnu: fifengine: Fix build.
* gnu/packages/patches/fifengine-boost-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/games.scm (fifengine)[source](patches): Add it. [arguments]: Remove defunct Python module import.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/fifengine-boost-compat.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/fifengine-boost-compat.patch b/gnu/packages/patches/fifengine-boost-compat.patch
new file mode 100644
index 0000000000..dcbf923297
--- /dev/null
+++ b/gnu/packages/patches/fifengine-boost-compat.patch
@@ -0,0 +1,17 @@
+Fix build with newer Boost.
+
+Taken from upstream:
+
+ https://github.com/fifengine/fifengine/commit/8072f18a9bf4e75c3e1b197b6ccda11e82954460
+
+diff --git a/engine/core/vfs/zip/zipnode.cpp b/engine/core/vfs/zip/zipnode.cpp
+--- a/engine/core/vfs/zip/zipnode.cpp
++++ b/engine/core/vfs/zip/zipnode.cpp
+@@ -28,6 +28,7 @@
+ #include "vfs/fife_boost_filesystem.h"
+
+ #include "zipnode.h"
++#include <algorithm>
+
+ namespace {
+ /** helper function to find a value in a ZipNodeContainer