summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 05:27:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 13:19:33 +0100
commit5bb12e1462c4ecfbed829b09ed011853dd74209d (patch)
tree75955d5cd58fe3de48fca690146d378e1ce0cc8e /gnu/packages/patches
parent5d0bd1fbbf00c3f8a06fc64b29f801780f4d46b2 (diff)
downloadguix-patches-5bb12e1462c4ecfbed829b09ed011853dd74209d.tar
guix-patches-5bb12e1462c4ecfbed829b09ed011853dd74209d.tar.gz
gnu: ninja: Update to 1.8.2.
* gnu/packages/ninja.scm (ninja): Update to 1.8.2. [source]: Remove upstreamed patch. [arguments]: Substitute INVOKE for SYSTEM*. Use standard indentation. * gnu/packages/patches/ninja-zero-mtime.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ninja-zero-mtime.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/patches/ninja-zero-mtime.patch b/gnu/packages/patches/ninja-zero-mtime.patch
deleted file mode 100644
index c9b9e8d798..0000000000
--- a/gnu/packages/patches/ninja-zero-mtime.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Work around a design defect in Ninja whereby a zero mtime is used to
-denote missing files (we happen to produce files that have a zero mtime
-and yet really do exist.)
-
---- ninja-1.5.3/src/disk_interface.cc 2014-11-24 18:37:47.000000000 +0100
-+++ ninja-1.5.3/src/disk_interface.cc 2015-07-18 23:20:38.572290139 +0200
-@@ -194,6 +194,12 @@ TimeStamp RealDiskInterface::Stat(const
- }
- return -1;
- }
-+
-+ if (st.st_mtime == 0)
-+ // All the code assumes that mtime == 0 means "file missing". Here we
-+ // know the file is not missing, so tweak the mtime.
-+ st.st_mtime = 1;
-+
- return st.st_mtime;
- #endif
- }