summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 19:32:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 19:36:40 +0100
commitb4263f12edd11ddc49c509116df11de6ae839ad2 (patch)
treea23ac1ca18a1091f5b371ea021de381333f60fc8 /gnu/packages/patches
parentb1cf1d44f402cef3fccbb37277554bc7d5dd27d4 (diff)
downloadguix-patches-b4263f12edd11ddc49c509116df11de6ae839ad2.tar
guix-patches-b4263f12edd11ddc49c509116df11de6ae839ad2.tar.gz
gnu: tremc: Fix execution with recent Python.
* gnu/packages/bittorrent.scm (tremc)[source]: Add patch. * gnu/packages/patches/tremc-fix-decodestring.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Reported by gnoo in #guix
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/tremc-fix-decodestring.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/tremc-fix-decodestring.patch b/gnu/packages/patches/tremc-fix-decodestring.patch
new file mode 100644
index 0000000000..346f65e611
--- /dev/null
+++ b/gnu/packages/patches/tremc-fix-decodestring.patch
@@ -0,0 +1,25 @@
+From 79995bc82e81f0429222aab4d90a03440feef057 Mon Sep 17 00:00:00 2001
+From: Matan Ziv-Av <matan@svgalib.org>
+Date: Mon, 29 Jun 2020 15:18:03 +0300
+Subject: [PATCH] Use base64.decodebytes.
+
+Based on upstream commit 79995bc82e81f0429222aab4d90a03440feef057 which
+confuses several unrelated changes.
+
+---
+ tremc | 29 ++++++++++++++++++++++++++++-
+ 1 file changed, 28 insertions(+), 1 deletion(-)
+
+diff --git a/tremc b/tremc
+index b47f012..c626fde 100755
+--- a/tremc
++++ b/tremc
+@@ -440,7 +443,7 @@ class Transmission(object):
+ # TAG_TORRENT_DETAILS, but just passing seems to help.(?)
+ try:
+ torrent_details = response['arguments']['torrents'][0]
+- torrent_details['pieces'] = base64.decodestring(bytes(torrent_details['pieces'], ENCODING))
++ torrent_details['pieces'] = base64.decodebytes(bytes(torrent_details['pieces'], ENCODING))
+ self.torrent_details_cache = torrent_details
+ self.upgrade_peerlist()
+ except IndexError: